summary refs log tree commit diff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-05-22 17:56:41 +0300
committerEfraim Flashner <efraim@flashner.co.il>2023-07-18 20:56:11 +0300
commit4f100111867ba3bb2955aa9b30050b9017f0aa2c (patch)
treeb0d496e26f312b6b2b6b8bd20e9abadf8a6d2953
parentce85fbb2b8111450b81d8e713c864774e5b8378b (diff)
downloadguix-4f100111867ba3bb2955aa9b30050b9017f0aa2c.tar.gz
gnu: Add rust-dot-writer-0.1.
* gnu/packages/crates-io.scm (rust-dot-writer-0.1): New variable.
-rw-r--r--gnu/packages/crates-io.scm18
1 files changed, 18 insertions, 0 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index c3fc6c2569..3bc94fa436 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -19751,6 +19751,24 @@ non-persistent vector.")
 for graphs.")
     (license (list license:expat license:asl2.0))))
 
+(define-public rust-dot-writer-0.1
+  (package
+    (name "rust-dot-writer")
+    (version "0.1.3")
+    (source (origin
+              (method url-fetch)
+              (uri (crate-uri "dot-writer" version))
+              (file-name (string-append name "-" version ".tar.gz"))
+              (sha256
+               (base32
+                "0yjv36hr3klzq4bpzkkqp64s8479ssabr7zkdxn4163ybsyi26rx"))))
+    (build-system cargo-build-system)
+    (home-page "https://bitbucket.org/DrGabble/dot-writer")
+    (synopsis "Library for writing the Graphviz DOT graph language")
+    (description
+     "This package provides a library for writing the Graphviz DOT graph language.")
+    (license license:expat)))
+
 (define-public rust-dotenv-0.15
   (package
     (name "rust-dotenv")