summary refs log tree commit diff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-03-31 16:04:13 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2019-04-10 20:53:59 +0200
commit517da53082b6d04e8a8db0e78fd035eb26ca24c9 (patch)
tree0dfe84b204ace0b8f054a74572fdd8aa19aaad8e
parentbe7344bed3ab2e80c66aa7f7398a4623275f9dab (diff)
downloadguix-517da53082b6d04e8a8db0e78fd035eb26ca24c9.tar.gz
gnu: emacs-page-break-lines: Don't use unstable tarball.
* gnu/packages/emacs-xyz.scm (emacs-page-break-lines)[source]: Use GIT-FETCH and
GIT-FILE-NAME.
-rw-r--r--gnu/packages/emacs-xyz.scm12
1 files changed, 6 insertions, 6 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index f913a4f36a..7d935be1ff 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -2382,13 +2382,13 @@ subconsciously blend out the parentheses.")
     (version "0.11")
     (source
      (origin
-       (method url-fetch)
-       (uri (string-append "https://github.com/purcell/page-break-lines/"
-                           "archive/" version ".tar.gz"))
-       (file-name (string-append name "-" version ".tar.gz"))
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/purcell/page-break-lines.git")
+             (commit version)))
+       (file-name (git-file-name name version))
        (sha256
-        (base32
-         "1zzhziq5kbrm9rxk30kx2glz455fp1blqxg8cpcf6l8xl3w8z4pg"))))
+        (base32 "1wp974716ih2cz9kdmdz7xwjy1qnnfzdzlfr9kchknagw8d9nn12"))))
     (build-system emacs-build-system)
     (home-page "https://github.com/purcell/page-break-lines")
     (synopsis "Display page breaks as tidy horizontal lines")