summary refs log tree commit diff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-06-29 13:00:18 +0300
committerEfraim Flashner <efraim@flashner.co.il>2023-07-18 20:56:15 +0300
commit57ce0f6186204dd040a1990113b68ba7303b973b (patch)
treebfb9e597edbe41a8b1b925a3d0ec7209d9c2ab5e
parentc71c92b97a09cfbcdbbf733e5b16c35b786b0513 (diff)
downloadguix-57ce0f6186204dd040a1990113b68ba7303b973b.tar.gz
gnu: newsboat: Update to 2.32.
* gnu/packages/syndication.scm (newsboat): Update to 2.32.
[native-inputs]: Use 'supported-package?'.
-rw-r--r--gnu/packages/syndication.scm7
1 files changed, 3 insertions, 4 deletions
diff --git a/gnu/packages/syndication.scm b/gnu/packages/syndication.scm
index 68c7fce26c..ac00d396b5 100644
--- a/gnu/packages/syndication.scm
+++ b/gnu/packages/syndication.scm
@@ -224,22 +224,21 @@ cards.")
 (define-public newsboat
   (package
     (name "newsboat")
-    (version "2.31")
+    (version "2.32")
     (source
      (origin
        (method url-fetch)
        (uri (string-append "https://newsboat.org/releases/" version
                            "/newsboat-" version ".tar.xz"))
        (sha256
-        (base32 "1nn1akjc3l29gcr0n6g7y39qvmbw8vf5sfmnxd794sgmbki7vbsb"))))
+        (base32 "1rp67fqsnsknlhlq75vgdjg9rggx8j7wbmixvps967m2f92m2qsv"))))
     (build-system cargo-build-system)
     (native-inputs
      `(("gettext" ,gettext-minimal)
        ("openssl" ,openssl)
        ("pkg-config" ,pkg-config)
        ;; For building documentation.
-       ,@(if (member (%current-system)
-                     (package-transitive-supported-systems ruby-asciidoctor))
+       ,@(if (supported-package? ruby-asciidoctor)
            `(("asciidoctor" ,ruby-asciidoctor))
            `())))
     (inputs