summary refs log tree commit diff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-05-03 10:21:58 +0300
committerEfraim Flashner <efraim@flashner.co.il>2023-05-03 11:39:59 +0300
commit59268c5ef1cd2a5a4be35705f2416a15c881c0ca (patch)
tree6fc067931839577e319bb4922a150851523681fe
parent47097b947b893215644510ebb7c6b9c3413683c5 (diff)
downloadguix-59268c5ef1cd2a5a4be35705f2416a15c881c0ca.tar.gz
gnu: python-numpy: Fix building for armhf-linux.
* gnu/packages/python-xyz.scm (python-numpy)[arguments]: Skip another
test in the 'check phase when building for armhf-linux.
-rw-r--r--gnu/packages/python-xyz.scm4
1 files changed, 4 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index e2d082091f..7950d4a775 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -6410,6 +6410,10 @@ include_dirs = ~:*~a/include~%"
                                      `(" and not test_identityless_reduction_huge_array"
                                        " and not (TestKind and test_all)")
                                    '())
+                              ;; This test fails when building from aarch64-linux.
+                              #$@(if (target-arm32?)
+                                   `(" and not test_features")
+                                   '())
                               ;; These tests seem to fail on machines without
                               ;; an FPU is still under investigation upstream.
                               ;; https://github.com/numpy/numpy/issues/20635