summary refs log tree commit diff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-07-13 12:35:21 +0300
committerEfraim Flashner <efraim@flashner.co.il>2023-07-18 20:56:18 +0300
commit59d7641886cc152234f8b398eaf4e222a1bd6e7e (patch)
tree95e11d7ca8e089174793d70b32e77df84cdf3657
parent5b6811932e061da3a5649a48c50dad9509a3d2fa (diff)
downloadguix-59d7641886cc152234f8b398eaf4e222a1bd6e7e.tar.gz
gnu: Add rust-rustc-rayon-0.5.
* gnu/packages/crates-io.scm (rust-rustc-rayon-0.5): New variable.
(rust-rustc-rayon-0.4): Inherit from rust-rustc-rayon-0.5.
-rw-r--r--gnu/packages/crates-io.scm43
1 files changed, 31 insertions, 12 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 12175d3f64..1ca8c4057f 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -54077,30 +54077,27 @@ It is automatically published using the compiler repository at
 hex conversion traits.")
     (license (list license:expat license:asl2.0))))
 
-(define-public rust-rustc-rayon-0.4
+(define-public rust-rustc-rayon-0.5
   (package
     (name "rust-rustc-rayon")
-    (version "0.4.0")
+    (version "0.5.0")
     (source (origin
               (method url-fetch)
               (uri (crate-uri "rustc-rayon" version))
               (file-name (string-append name "-" version ".tar.gz"))
               (sha256
                (base32
-                "0ykjr1i56jmi8ykkcr7x555wnxki1vsi703mz6n2x7k0naqg0y8s"))))
+                "040p2am25g3isnpsixrcrjrv70yz2lzkbq8gpv76xjipi3fam0gb"))))
     (build-system cargo-build-system)
     (arguments
-     `(#:tests? #f                      ;XXX can not find rayon?
-       #:cargo-inputs
-       (("rust-autocfg" ,rust-autocfg-1)
-        ("rust-crossbeam-deque" ,rust-crossbeam-deque-0.7)
-        ("rust-either" ,rust-either-1)
-        ("rust-rustc-rayon-core" ,rust-rustc-rayon-core-0.4))
+     `(#:cargo-inputs
+       (("rust-either" ,rust-either-1)
+        ("rust-rustc-rayon-core" ,rust-rustc-rayon-core-0.5))
        #:cargo-development-inputs
-       (("rust-docopt" ,rust-docopt-1))))
+       (("rust-rand" ,rust-rand-0.8)
+        ("rust-rand-xorshift" ,rust-rand-xorshift-0.3))))
     (home-page "https://github.com/rust-lang/rustc-rayon")
-    (synopsis
-     "Simple work-stealing parallelism for Rust - fork for rustc")
+    (synopsis "Simple work-stealing parallelism for Rust - fork for rustc")
     (description
      "Rustc-rayon is a fork of the Rayon crate.  It adds a few \"in progress\"
 features that rustc is using, mostly around deadlock detection.  These features
@@ -54109,6 +54106,28 @@ way into rayon proper at some point.  In general, if you are not rustc, you
 should be using the real rayon crate, not rustc-rayon.")
     (license (list license:asl2.0 license:expat))))
 
+(define-public rust-rustc-rayon-0.4
+  (package
+    (inherit rust-rustc-rayon-0.5)
+    (name "rust-rustc-rayon")
+    (version "0.4.0")
+    (source (origin
+              (method url-fetch)
+              (uri (crate-uri "rustc-rayon" version))
+              (file-name (string-append name "-" version ".tar.gz"))
+              (sha256
+               (base32
+                "0ykjr1i56jmi8ykkcr7x555wnxki1vsi703mz6n2x7k0naqg0y8s"))))
+    (arguments
+     `(#:tests? #f                      ;XXX can not find rayon?
+       #:cargo-inputs
+       (("rust-autocfg" ,rust-autocfg-1)
+        ("rust-crossbeam-deque" ,rust-crossbeam-deque-0.7)
+        ("rust-either" ,rust-either-1)
+        ("rust-rustc-rayon-core" ,rust-rustc-rayon-core-0.4))
+       #:cargo-development-inputs
+       (("rust-docopt" ,rust-docopt-1))))))
+
 (define-public rust-rustc-rayon-core-0.5
   (package
     (name "rust-rustc-rayon-core")