summary refs log tree commit diff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-10-10 10:41:27 +0300
committerEfraim Flashner <efraim@flashner.co.il>2021-10-10 12:31:31 +0300
commit5a8ff5775cfed384a02978231547d34591139501 (patch)
tree6e836abf086d6094fa9c39b66a188dd73dcdd759
parent65b8f870a16e72bf1d4b7cdc85bc1088ca59046a (diff)
downloadguix-5a8ff5775cfed384a02978231547d34591139501.tar.gz
gnu: rust-fastrand-1: Update to 1.5.0.
* gnu/packages/crates-io.scm (rust-fastrand-1): Update to 1.5.0.
[cargo-development-inputs]: Replace rust-rand-0.7 with 0.8. Add
rust-getrandom-0.2, rust-instant-0.1, rust-wasm-bindgen-test-0.3,
rust-wyhash-0.5.
-rw-r--r--gnu/packages/crates-io.scm10
1 files changed, 7 insertions, 3 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 772aaeaf8e..3a062deba1 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -16562,20 +16562,24 @@ floats.")
 (define-public rust-fastrand-1
   (package
     (name "rust-fastrand")
-    (version "1.4.0")
+    (version "1.5.0")
     (source
      (origin
        (method url-fetch)
        (uri (crate-uri "fastrand" version))
        (file-name (string-append name "-" version ".tar.gz"))
        (sha256
-        (base32 "1qvz1i7g5mb2hcsaawrvxx88b8vwrsr85qr98ffmrkj5fh2sypya"))))
+        (base32 "0birvh29m4x6nwjdyrmiyiypw9l52bmvk15ksdw96hjs50yyv55k"))))
     (build-system cargo-build-system)
     (arguments
      `(#:cargo-inputs
        (("rust-instant" ,rust-instant-0.1))
        #:cargo-development-inputs
-       (("rust-rand" ,rust-rand-0.7))))
+       (("rust-getrandom" ,rust-getrandom-0.2)
+        ("rust-instant" ,rust-instant-0.1)
+        ("rust-rand" ,rust-rand-0.8)
+        ("rust-wasm-bindgen-test" ,rust-wasm-bindgen-test-0.3)
+        ("rust-wyhash" ,rust-wyhash-0.5))))
     (home-page "https://github.com/stjepang/fastrand")
     (synopsis "Simple and fast random number generator")
     (description