summary refs log tree commit diff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-04-29 23:37:03 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-05-31 14:53:34 -0400
commit5ab0cbd0f1e0fa7cca3052a51f032460fb3bb17c (patch)
tree1d28c5829fc0d29731a9a7da52788f657cdbb898
parent4f18b13436f52c107e66056a9dd3a13bb99c8030 (diff)
downloadguix-5ab0cbd0f1e0fa7cca3052a51f032460fb3bb17c.tar.gz
gnu: Remove python2-numpy.
* gnu/packages/python-xyz.scm (python2-numpy): Delete variable.
(python2-numpy-1.8): Likewise.
(python-numpy)[properties]: Delete field.
* gnu/packages/maths.scm (flann): Delete comment.
* gnu/packages/chemistry.scm (with-numpy-1.8): Delete procedure.
-rw-r--r--gnu/packages/chemistry.scm3
-rw-r--r--gnu/packages/maths.scm1
-rw-r--r--gnu/packages/python-xyz.scm69
3 files changed, 0 insertions, 73 deletions
diff --git a/gnu/packages/chemistry.scm b/gnu/packages/chemistry.scm
index e5b6309585..735d599d2d 100644
--- a/gnu/packages/chemistry.scm
+++ b/gnu/packages/chemistry.scm
@@ -303,9 +303,6 @@ with templates to facilitate the execution of the program.  Input files can be
 staged, and output files collected using a standard interface.")
     (license license:bsd-3)))
 
-(define with-numpy-1.8
-  (package-input-rewriting `((,python2-numpy . ,python2-numpy-1.8))))
-
 (define-public tng
   (package
     (name "tng")
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 16faf1ec18..9cecf5cc40 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -5366,7 +5366,6 @@ in finite element programs.")
        ;; Disable it for now.
        ;;("octave" ,octave-cli)
        ("python" ,python-2) ; print syntax
-       ;; ("python2-numpy" ,python2-numpy) ; only required for the tests
        ("zlib" ,zlib)))
     (arguments
      `(;; The 'share/flann/octave' contains a .mex file, which is an ELF file
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 8981ca0e47..df27279e6d 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -5614,7 +5614,6 @@ with Python.  It contains among other things: a powerful N-dimensional array
 object, sophisticated (broadcasting) functions, tools for integrating C/C++
 and Fortran code, useful linear algebra, Fourier transform, and random number
 capabilities.")
-    (properties `((python2-variant . ,(delay python2-numpy))))
     (license license:bsd-3)))
 
 (define-public python-numpy-next
@@ -5726,74 +5725,6 @@ capabilities.")
     (description "This package provides the complete NumPy documentation in
 the Texinfo, HTML, and PDF formats.")))
 
-;; Numpy 1.16.x are the last versions that support Python 2.
-(define-public python2-numpy
-  (let ((numpy (package-with-python2
-                (strip-python2-variant python-numpy))))
-    (package
-      (inherit numpy)
-      (name "python2-numpy")
-      (version "1.16.5")
-      (source (origin
-                (method url-fetch)
-                (uri (string-append
-                      "https://github.com/numpy/numpy/releases/download/v"
-                      version "/numpy-" version ".tar.gz"))
-                (sha256
-                 (base32
-                  "0lg1cycxzi4rvvrd5zxinpdz0ni792fpx6xjd75z1923zcac8qrb"))))
-      (arguments
-       (substitute-keyword-arguments (package-arguments numpy)
-         ((#:phases phases)
-          #~(modify-phases #$phases
-              (add-after 'unpack 'delete-failing-tests
-                (lambda _
-                  ;; There's just one failing test here.
-                  (delete-file "numpy/linalg/tests/test_linalg.py")
-                  ;; ...and this one depends on the previous one.
-                  (delete-file "numpy/matrixlib/tests/test_matrix_linalg.py")))
-              (replace 'check
-                ;; Older versions don't cope well with the extra Pytest
-                ;; options, so remove them.
-                (lambda* (#:key tests? outputs inputs #:allow-other-keys)
-                  (when tests?
-                    (invoke "./runtests.py" "-vv" "--no-build" "--mode=fast"
-                            "-j" (number->string (parallel-job-count))))))))))
-      (native-inputs
-       (list python2-cython python2-pytest gfortran)))))
-
-;; NOTE: NumPy 1.8 is packaged only for Python 2 because it is of
-;; interest only for legacy code going back to NumPy's predecessor
-;; Numeric.
-(define-public python2-numpy-1.8
-  (package
-    (inherit python2-numpy)
-    (version "1.8.2")
-    (source
-     (origin
-       (method git-fetch)
-       (uri (git-reference
-             (url "https://github.com/numpy/numpy")
-             (commit (string-append "v" version))))
-       (file-name (git-file-name "numpy" version))
-       (sha256
-        (base32
-         "0ikgi15rsqwbkfsjjxrwh40lqyal2wvyp3923y6w6ch3dcr82sfk"))))
-    (arguments (substitute-keyword-arguments (package-arguments python2-numpy)
-                 ((#:tests? _ #f) #f)   ;disable tests
-                 ((#:phases phases)
-                  #~(modify-phases #$phases
-                      (delete 'delete-failing-tests)))))
-    (native-inputs '())
-    (description "NumPy is the fundamental package for scientific computing
-with Python.  It contains among other things: a powerful N-dimensional array
-object, sophisticated (broadcasting) functions, tools for integrating C/C++
-and Fortran code, useful linear algebra, Fourier transform, and random number
-capabilities.  Version 1.8 is the last one to contain the numpy.oldnumeric API
-that includes the compatibility layer numpy.oldnumeric with NumPy's predecessor
-Numeric.")
-    (license license:bsd-3)))
-
 (define-public python-munch
   (package
     (name "python-munch")