summary refs log tree commit diff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2023-05-12 22:23:23 +0200
committerRicardo Wurmus <rekado@elephly.net>2023-05-12 22:23:23 +0200
commit5d446e439dfe1aa1a0ff68d52ed0f16ef3490e2f (patch)
tree3d49f998d06fb6a5dcbe8bd10f4dd39dda470908
parentfac8721bfd9516fec63c39c2bfe8ccbd3f6f0e1e (diff)
downloadguix-5d446e439dfe1aa1a0ff68d52ed0f16ef3490e2f.tar.gz
gnu: phast: Simplify by using G-expression.
* gnu/packages/bioinformatics.scm (phast)[arguments]: Use G-expression and
drop trailing #T from build phases.
-rw-r--r--gnu/packages/bioinformatics.scm75
1 files changed, 37 insertions, 38 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index b3576159ed..99344b168a 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -17902,44 +17902,43 @@ containing the reference genome as well.")
                 "10lpbllvny923jjbbyrpxahhd1m5h7sbj9gx7rd123rg10mlidki"))))
     (build-system gnu-build-system)
     (arguments
-     `(#:make-flags
-       ,#~(list "CC=gcc"
-                (string-append "DESTDIR=" #$output))
-       #:phases
-       (modify-phases %standard-phases
-         (replace 'configure
-           (lambda* (#:key inputs outputs #:allow-other-keys)
-             ;; Fix syntax
-             (substitute* "test/Makefile"
-               (("        ") "	"))
-             (substitute* "Makefile"
-               (("CLAPACKPATH=/usr/lib")
-                (string-append "CLAPACKPATH="
-                               (assoc-ref inputs "clapack") "/lib")))
-             ;; Renaming the libraries is not necessary with our version of
-             ;; CLAPACK.
-             (substitute* "src/lib/Makefile"
-               (("ifdef CLAPACKPATH") "ifdef UNNECESSARY"))
-             (substitute* "src/make-include.mk"
-               (("-lblaswr") "-lblas")
-               (("-ltmg") "-ltmglib")
-               (("liblapack.a") "liblapack.so")
-               (("libblas.a") "libblas.so")
-               (("libf2c.a") "libf2c.so"))
-             (substitute* "src/Makefile"
-               (("/opt") "/share")
-               (("/usr/") "/"))
-             #t))
-         (replace 'check
-           (lambda _
-             (setenv "PATH"
-                     (string-append (getcwd) "/bin:" (getenv "PATH")))
-             ;; Disable broken test
-             (substitute* "test/Makefile"
-               ((".*if.*hmrc_summary" m) (string-append "#" m)))
-             ;; Only run the msa_view tests because the others fail for
-             ;; unknown reasons.
-             (invoke "make" "-C" "test" "msa_view"))))))
+     (list
+      #:make-flags
+      #~(list "CC=gcc" (string-append "DESTDIR=" #$output))
+      #:phases
+      #~(modify-phases %standard-phases
+          (replace 'configure
+            (lambda* (#:key inputs outputs #:allow-other-keys)
+              ;; Fix syntax
+              (substitute* "test/Makefile"
+                (("        ") "	"))
+              (substitute* "Makefile"
+                (("CLAPACKPATH=/usr/lib")
+                 (string-append "CLAPACKPATH="
+                                #$(this-package-input "clapack") "/lib")))
+              ;; Renaming the libraries is not necessary with our version of
+              ;; CLAPACK.
+              (substitute* "src/lib/Makefile"
+                (("ifdef CLAPACKPATH") "ifdef UNNECESSARY"))
+              (substitute* "src/make-include.mk"
+                (("-lblaswr") "-lblas")
+                (("-ltmg") "-ltmglib")
+                (("liblapack.a") "liblapack.so")
+                (("libblas.a") "libblas.so")
+                (("libf2c.a") "libf2c.so"))
+              (substitute* "src/Makefile"
+                (("/opt") "/share")
+                (("/usr/") "/"))))
+          (replace 'check
+            (lambda _
+              (setenv "PATH"
+                      (string-append (getcwd) "/bin:" (getenv "PATH")))
+              ;; Disable broken test
+              (substitute* "test/Makefile"
+                ((".*if.*hmrc_summary" m) (string-append "#" m)))
+              ;; Only run the msa_view tests because the others fail for
+              ;; unknown reasons.
+              (invoke "make" "-C" "test" "msa_view"))))))
     (inputs
      (list clapack))
     (native-inputs