summary refs log tree commit diff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-11-26 11:00:17 +0200
committerEfraim Flashner <efraim@flashner.co.il>2021-11-26 11:00:17 +0200
commit5d93e9e36a9927f77e789293e2db7c42be199024 (patch)
tree1339e3c585456d150a398d5846e1a79a14046ca9
parent4b632fb86486e58e859049dbd56e8956fe58961f (diff)
downloadguix-5d93e9e36a9927f77e789293e2db7c42be199024.tar.gz
gnu: git-annex: Honor the #:tests? flag.
* gnu/packages/haskell-apps.scm (git-annex)[arguments]: Adjust the
custom 'check phase to honor the #:tests? flag.
-rw-r--r--gnu/packages/haskell-apps.scm10
1 files changed, 5 insertions, 5 deletions
diff --git a/gnu/packages/haskell-apps.scm b/gnu/packages/haskell-apps.scm
index 2a07aa547d..8ef5bb5788 100644
--- a/gnu/packages/haskell-apps.scm
+++ b/gnu/packages/haskell-apps.scm
@@ -372,15 +372,15 @@ to @code{cabal repl}).")
                  (format out "main = buildMansOrWarn~%")))
              (invoke "runhaskell" "Build/MakeMans.hs")))
          (replace 'check
-           (lambda _
+           (lambda* (#:key tests? #:allow-other-keys)
              ;; We need to set the path so that Git recognizes
              ;; `git annex' as a custom command.
              (setenv "PATH" (string-append (getenv "PATH") ":"
                                            (getcwd) "/dist/build/git-annex"))
-             (with-directory-excursion "dist/build/git-annex"
-               (symlink "git-annex" "git-annex-shell"))
-             (invoke "git-annex" "test")
-             #t))
+             (when tests?
+               (with-directory-excursion "dist/build/git-annex"
+                 (symlink "git-annex" "git-annex-shell"))
+               (invoke "git-annex" "test"))))
          (add-after 'check 'unpatch-shell-and-rebuild
            (lambda args
              ;; Undo `patch-shell-for-tests'.