summary refs log tree commit diff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-01-01 18:45:38 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-01-03 16:03:26 -0500
commit5dc8cf849ba70a79217f66cc9feab793fc095902 (patch)
treecc66ab7ba17b77714004e2049c6408d6804ee541
parenta5b00d2733d817df35c54749789be69bd53f66fd (diff)
downloadguix-5dc8cf849ba70a79217f66cc9feab793fc095902.tar.gz
gnu: dtc: Install documentation.
* gnu/packages/bootloaders.scm (dtc) [modules]: New argument.
[phases]: Add install-doc phase.
-rw-r--r--gnu/packages/bootloaders.scm11
1 files changed, 10 insertions, 1 deletions
diff --git a/gnu/packages/bootloaders.scm b/gnu/packages/bootloaders.scm
index 41e33a24b5..029672721f 100644
--- a/gnu/packages/bootloaders.scm
+++ b/gnu/packages/bootloaders.scm
@@ -575,6 +575,7 @@ The SUBDIR argument defaults to \"efi/Guix\", as it is also the case for
     (build-system gnu-build-system)
     (arguments
      (list
+      #:modules `(,@%gnu-build-system-modules (srfi srfi-26))
       #:make-flags
       #~(list (string-append "CC=" #$(cc-for-target))
               ;; /bin/fdt{get,overlay,put} need help finding libfdt.so.1.
@@ -590,7 +591,15 @@ The SUBDIR argument defaults to \"efi/Guix\", as it is also the case for
                              "tests/run_tests.sh")
                 (("pkg-config")
                  #$(pkg-config-for-target)))))
-          (delete 'configure))))        ;no configure script
+          (delete 'configure)           ;no configure script
+          (add-before 'build 'install-doc
+            (lambda _
+              (with-directory-excursion "Documentation"
+                (for-each (cut install-file <> (string-append
+                                                #$output "/share/doc/dtc/"))
+                          '("dts-format.txt"
+                            "dt-object-internal.txt"
+                            "manual.txt"))))))))
     (native-inputs
      (append
       (list bison