summary refs log tree commit diff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2018-02-12 20:47:26 +0100
committerRicardo Wurmus <rekado@elephly.net>2018-02-13 13:37:33 +0100
commit5e51bcf7b38511d943f4d24621be5817144061cd (patch)
tree11a5edc64670fff808ef07b054ca356a50d90e2f
parent5e3840e250f89ec8a7cc22ae747e51262edff54c (diff)
downloadguix-5e51bcf7b38511d943f4d24621be5817144061cd.tar.gz
gnu: Add ghc-time-locale-compat.
* gnu/packages/haskell.scm (ghc-time-locale-compat): New variable.
-rw-r--r--gnu/packages/haskell.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 4fd6c2f4dd..4061d5f201 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -2300,6 +2300,27 @@ the parsers provided by @code{parsec}, @code{attoparsec} and @code{base}'s
 with slicing and Clang-style colored diagnostics.")
     (license license:bsd-3)))
 
+(define-public ghc-time-locale-compat
+  (package
+    (name "ghc-time-locale-compat")
+    (version "0.1.1.3")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "https://hackage.haskell.org/package/"
+                           "time-locale-compat/time-locale-compat-"
+                           version ".tar.gz"))
+       (sha256
+        (base32
+         "1vdcfr2hp9qh3ag90x6ikbdf42wiqpdylnplffna54bpnilbyi4i"))))
+    (build-system haskell-build-system)
+    (inputs `(("ghc-old-locale" ,ghc-old-locale)))
+    (home-page "https://github.com/khibino/haskell-time-locale-compat")
+    (synopsis "Compatibility of TimeLocale between old-locale and time-1.5")
+    (description "This package contains a wrapped name module for
+@code{TimeLocale}.")
+    (license license:bsd-3)))
+
 (define-public ghc-attoparsec
   (package
     (name "ghc-attoparsec")