summary refs log tree commit diff
diff options
context:
space:
mode:
authorMădălin Ionel Patrașcu <madalinionel.patrascu@mdc-berlin.de>2023-02-27 22:17:44 +0100
committerRicardo Wurmus <rekado@elephly.net>2023-03-01 12:19:56 +0100
commit5fdf7e9ab943e42ec8096d310791148652c82079 (patch)
treefc65426ad3260901fe944bbd5dbf6bb8dbedfe35
parent2eb750ab1f1175cb20483175afa8d5143b3158cd (diff)
downloadguix-5fdf7e9ab943e42ec8096d310791148652c82079.tar.gz
gnu: Add r-rcppspdlog.
* gnu/packages/cran.scm (r-rcppspdlog): New variable.
-rw-r--r--gnu/packages/cran.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index abf2868122..6db37eddf0 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -4992,6 +4992,30 @@ performs global optimization by differential evolution.")
 factorization and divisive clustering for large sparse and dense matrices.")
     (license license:gpl2+)))
 
+(define-public r-rcppspdlog
+  (package
+    (name "r-rcppspdlog")
+    (version "0.0.12")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "RcppSpdlog" version))
+       (sha256
+        (base32 "1nan0hm49xdl2l1lskm1jf01clfh7aw2v6h57j35qysvg8219fcx"))))
+    (properties `((upstream-name . "RcppSpdlog")))
+    (build-system r-build-system)
+    (propagated-inputs (list r-rcpp))
+    (native-inputs (list r-simplermarkdown))
+    (home-page "https://github.com/eddelbuettel/rcppspdlog")
+    (synopsis "R and C++ interfaces to spdlog C++ header library for logging")
+    (description
+     "The spdlog library is a widely-used and very capable header-only C++
+library for logging.  This package includes its headers as an R package to
+permit other R packages to deploy it via a simple @code{LinkingTo:
+RcppSpdlog}.  As of version 0.0.9, it also provides both simple R logging
+functions and compiled functions callable by other packages.")
+    (license license:gpl2+)))
+
 (define-public r-rcppthread
   (package
     (name "r-rcppthread")