summary refs log tree commit diff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-11-18 08:30:35 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-11-18 11:40:11 -0500
commit61576d592714610d77200a56e154784a5c8b051e (patch)
tree6af2cd6ac7268cf60900e2d5499faf52d3bf58d7
parent416c70672937be367eeaa4f02e0fdbf9698dd517 (diff)
downloadguix-61576d592714610d77200a56e154784a5c8b051e.tar.gz
gnu: python-dbusmock: Patch reference to dbus-daemon.
* gnu/packages/python-xyz.scm (python-dbusmock)
[phases]{patch-shell-path}: Rename to...
{patch-paths}: ... this, and also patch the dbus-daemon reference.
-rw-r--r--gnu/packages/python-xyz.scm12
1 files changed, 9 insertions, 3 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 43ba2198e6..603ef2a7f0 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -23620,15 +23620,21 @@ for YAML and JSON.")
     (arguments
      '(#:phases
        (modify-phases %standard-phases
-         (add-after 'unpack 'patch-shell-path
-           (lambda _
+         (add-after 'unpack 'patch-paths
+           (lambda* (#:key inputs #:allow-other-keys)
              (substitute* "tests/test_code.py"
-               (("/bin/bash") (which "bash"))))))))
+               (("/bin/bash") (which "bash")))
+             (substitute* "dbusmock/testcase.py"
+               (("'dbus-daemon'")
+                (string-append "'" (assoc-ref inputs "dbus")
+                               "/bin/dbus-daemon'"))))))))
     (native-inputs
      `(;; For tests.
        ("dbus" ,dbus) ; for dbus-daemon
        ("python-nose" ,python-nose)
        ("which" ,which)))
+    (inputs
+     `(("dbus" ,dbus)))
     (propagated-inputs
      `(("python-dbus" ,python-dbus)
        ("python-pygobject" ,python-pygobject)))