summary refs log tree commit diff
diff options
context:
space:
mode:
authorEric Dvorsak <eric@dvorsak.fr>2015-08-17 05:05:37 +0200
committerEric Bavier <bavier@member.fsf.org>2015-08-23 11:32:09 -0500
commit63b1bdbc43a4ab23a558c403bd377909b38d966f (patch)
tree0ad4de73e71299707d4c6edf0c726a3db3053b9e
parent5c37126f68a127edf140051651f25771a4db8a11 (diff)
downloadguix-63b1bdbc43a4ab23a558c403bd377909b38d966f.tar.gz
gnu: Add i3status.
* gnu/packages/wm.scm (i3status): New variable.

Signed-off-by: Eric Bavier <bavier@member.fsf.org>
-rw-r--r--gnu/packages/wm.scm37
1 files changed, 37 insertions, 0 deletions
diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index 0106cdd442..6f05b88bbb 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -60,6 +60,43 @@ single/double-quoted strings, environment variable expansion, functions and
 nested include statements).")
     (license isc)))
 
+(define-public i3status
+  (package
+    (name "i3status")
+    (version "2.9")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "http://i3wm.org/i3status/i3status-"
+                                  version ".tar.bz2"))
+              (sha256
+               (base32
+                "1qwxbrga2fi5wf742hh9ajwa8b2kpzkjjnhjlz4wlpv21i80kss2"))))
+    (build-system gnu-build-system)
+    (arguments
+     `(#:make-flags (list "CC=gcc" (string-append "PREFIX=" %output))
+       #:phases
+       (modify-phases %standard-phases
+         (delete 'configure))
+       #:tests? #f)) ; no test suite
+    (inputs
+     `(("openlibm" ,openlibm)
+       ("libconfuse" ,libconfuse)
+       ("libyajl" ,libyajl)
+       ("alsa-lib" ,alsa-lib)
+       ("wireless-tools" ,wireless-tools)
+       ("libcap" ,libcap)
+       ("asciidoc" ,asciidoc)))
+    (home-page "http://i3wm.org/i3status/")
+    (synopsis "Status bar for i3bar, dzen2, xmobar or similar programs")
+    (description "i3status is a small program for generating a status bar for
+i3bar, dzen2, xmobar or similar programs.  It is designed to be very efficient
+by issuing a very small number of system calls, as one generally wants to
+update such a status line every second.  This ensures that even under high
+load, your status bar is updated correctly.  Also, it saves a bit of energy by
+not hogging your CPU as much as spawning the corresponding amount of shell
+commands would.")
+    (license bsd-3)))
+
 (define-public i3-wm
   (package
     (name "i3-wm")