summary refs log tree commit diff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2022-10-30 02:00:01 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2022-10-30 02:00:26 +0100
commit63d2348aaab604f136c2858d38b9eb3ae169e777 (patch)
tree8f10bfe76508105ab94f1447616f2a86e7c5b640
parent7174391cacbf25ccce70581d1593294074a70c59 (diff)
downloadguix-63d2348aaab604f136c2858d38b9eb3ae169e777.tar.gz
gnu: pam-mount: Use G-expressions.
* gnu/packages/admin.scm (pam-mount)[arguments]:
Rewrite as G-expressions.
-rw-r--r--gnu/packages/admin.scm57
1 files changed, 29 insertions, 28 deletions
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index 8cd0331449..bea94a4842 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -4634,34 +4634,35 @@ tcpdump and snoop.")
         (base32 "0832nh2qf9pisgwnbgx6hkylx5d7i416l19y3ly4ifv7k1p7mxqa"))))
     (build-system gnu-build-system)
     (arguments
-     `(#:configure-flags
-       (list (string-append "--with-slibdir=" %output "/lib")
-             (string-append "--with-ssbindir=" %output "/sbin"))
-       #:phases
-       (modify-phases %standard-phases
-         (add-after 'unpack 'patch-file-names
-           (lambda* (#:key inputs outputs #:allow-other-keys)
-             (let ((out (assoc-ref outputs "out")))
-               (substitute* "src/mtcrypt.c"
-                 (("\"(mount|umount)\";" _ command)
-                  (format #f "\"~a\";"
-                          (search-input-file inputs
-                                             (string-append "bin/" command))))
-                 (("\"(fsck)\"," _ command)
-                  (format #f "\"~a\","
-                          (search-input-file inputs
-                                             (string-append "sbin/" command)))))
-               (substitute* "src/rdconf1.c"
-                 (("\"(mount|umount)\", \"" _ command)
-                  (format #f "\"~a\", \""
-                          (search-input-file inputs
-                                             (string-append "bin/" command))))
-                 (("\"(fsck)\", \"" _ command)
-                  (format #f "\"~a\", \""
-                          (search-input-file inputs
-                                             (string-append "sbin/" command))))
-                 (("\"pmvarrun\", \"")
-                  (format #f "\"~a/sbin/pmvarrun\", \"" out)))))))))
+     (list
+      #:configure-flags
+      #~(list (string-append "--with-slibdir=" #$output "/lib")
+              (string-append "--with-ssbindir=" #$output "/sbin"))
+      #:phases
+      #~(modify-phases %standard-phases
+          (add-after 'unpack 'patch-file-names
+            (lambda* (#:key inputs outputs #:allow-other-keys)
+              (let ((out (assoc-ref outputs "out")))
+                (substitute* "src/mtcrypt.c"
+                  (("\"(mount|umount)\";" _ command)
+                   (format #f "\"~a\";"
+                           (search-input-file inputs
+                                              (string-append "bin/" command))))
+                  (("\"(fsck)\"," _ command)
+                   (format #f "\"~a\","
+                           (search-input-file inputs
+                                              (string-append "sbin/" command)))))
+                (substitute* "src/rdconf1.c"
+                  (("\"(mount|umount)\", \"" _ command)
+                   (format #f "\"~a\", \""
+                           (search-input-file inputs
+                                              (string-append "bin/" command))))
+                  (("\"(fsck)\", \"" _ command)
+                   (format #f "\"~a\", \""
+                           (search-input-file inputs
+                                              (string-append "sbin/" command))))
+                  (("\"pmvarrun\", \"")
+                   (format #f "\"~a/sbin/pmvarrun\", \"" out)))))))))
     (native-inputs
      (list perl pkg-config))
     (inputs