summary refs log tree commit diff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-09-08 00:01:25 +0200
committerRicardo Wurmus <rekado@elephly.net>2019-09-08 00:30:32 +0200
commit6983178b06f1efe61dc513d5b3fe1673c63ff47d (patch)
treee3daf9237920e3e2e621d140620f1db0d42dba9f
parent7a5ed348c0073cb28dae01c10b25155e29188fdb (diff)
downloadguix-6983178b06f1efe61dc513d5b3fe1673c63ff47d.tar.gz
gnu: Add r-systemfonts.
* gnu/packages/cran.scm (r-systemfonts): New variable.
-rw-r--r--gnu/packages/cran.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 44913e53f7..bdfc3fb2c9 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -15244,3 +15244,32 @@ It is an indirect measure of test quality and completeness.  This package is
 compatible with any testing methodology or framework and tracks coverage of
 both R code and compiled C/C++/FORTRAN code.")
     (license license:gpl3)))
+
+(define-public r-systemfonts
+  (package
+    (name "r-systemfonts")
+    (version "0.1.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "systemfonts" version))
+       (sha256
+        (base32
+         "0m0ljid683xcam2f14x7k2zv1yx4npac38a3gfv11vhxfbnpgp0z"))))
+    (properties `((upstream-name . "systemfonts")))
+    (build-system r-build-system)
+    (inputs
+     `(("fontconfig" ,fontconfig)
+       ("freetype" ,freetype)
+       ("zlib" ,zlib)))
+    (native-inputs
+     `(("pkg-config" ,pkg-config)))
+    (home-page "https://github.com/r-lib/systemfonts")
+    (synopsis "System native font finding")
+    (description
+     "This package provides system native access to the font catalogue.  As
+font handling varies between systems it is difficult to correctly locate
+installed fonts across different operating systems.  The 'systemfonts' package
+provides bindings to the native libraries for finding font files that can then
+be used further by e.g. graphic devices.")
+    (license license:expat)))