summary refs log tree commit diff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2021-09-21 21:30:41 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2021-09-23 18:17:15 +0200
commit6b035ad2fa028d923ea09c8e2a363b318df91538 (patch)
treed0644a5771ae04ceeea8fec2bf8b198754a269cc
parente1401fb7275e4630de730658f3169697013f4321 (diff)
downloadguix-6b035ad2fa028d923ea09c8e2a363b318df91538.tar.gz
gnu: rsync: Enable zstd & lz4 compression.
Both are ridiculously more suited to this role than the old zlib
compressor.  The closure size increase is negligible (1 MiB or 1.3% for
zstd, 1.7 MiB for both).

* gnu/packages/rsync.scm (rsync-next)[inputs]: Add zstd:lib and lz4.
[arguments]: Remove the corresponding "--disable-zstd" and
"--disable-lz4" #:configure-flags.
-rw-r--r--gnu/packages/rsync.scm8
1 files changed, 4 insertions, 4 deletions
diff --git a/gnu/packages/rsync.scm b/gnu/packages/rsync.scm
index 59460f1324..956c942770 100644
--- a/gnu/packages/rsync.scm
+++ b/gnu/packages/rsync.scm
@@ -87,16 +87,16 @@ files in the destination.")
       (list "--without-included-zlib"
             "--without-included-popt"
             ;; Avoid these dependencies for now.
-            "--disable-lz4"
-            "--disable-openssl"
-            "--disable-zstd")))
+            "--disable-openssl")))
    (native-inputs
     `(("perl" ,perl)))
    (inputs
     `(("acl" ,acl)
+      ("lz4" ,lz4)
       ("popt" ,popt)
       ("xxhash" ,xxhash)
-      ("zlib" ,zlib)))
+      ("zlib" ,zlib)
+      ("zstd:lib" ,zstd "lib")))
    (synopsis "Remote (and local) file copying tool")
    (description
     "Rsync is a fast and versatile file copying tool.  It can copy locally,