summary refs log tree commit diff
diff options
context:
space:
mode:
authorJohn Soo <jsoo1@asu.edu>2020-01-14 09:09:22 -0800
committerEfraim Flashner <efraim@flashner.co.il>2020-01-20 11:16:34 +0200
commit6b35ddf612c6edfdc9231134976f0af8d13fc424 (patch)
tree4085dbfd303883ef90389c9b91dc02b0976e96cf
parentbc3c2aacd39165b1949ee440e773427f5e1fd075 (diff)
downloadguix-6b35ddf612c6edfdc9231134976f0af8d13fc424.tar.gz
gnu: Update rust-rand-chacha-0.2 to 0.2.1.
* gnu/packages/crates-io.scm (rust-rand-chacha-0.2): Update to 0.2.1.
[arguments]: Remove rust-autocfg-0.1 from cargo-development-inputs.

Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
-rw-r--r--gnu/packages/crates-io.scm8
1 files changed, 3 insertions, 5 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 66d3b52d99..10e19d4114 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -7689,7 +7689,7 @@ useful types and distributions, and some randomness-related algorithms.")
 (define-public rust-rand-chacha-0.2
   (package
     (name "rust-rand-chacha")
-    (version "0.2.0")
+    (version "0.2.1")
     (source
      (origin
        (method url-fetch)
@@ -7698,15 +7698,13 @@ useful types and distributions, and some randomness-related algorithms.")
         (string-append name "-" version ".tar.gz"))
        (sha256
         (base32
-         "178d36jfkc4v95s25scc2vibj2hd2hlk64cs6id4hvzg89whd4z1"))))
+         "0lv8imzzl4h2glm6sjj8mkvasgi8jym23ya48dakyln7m06sk8h3"))))
     (build-system cargo-build-system)
     (arguments
      `(#:skip-build? #t
        #:cargo-inputs
        (("rust-c2-chacha" ,rust-c2-chacha-0.2)
-        ("rust-rand-core" ,rust-rand-core-0.5))
-       #:cargo-development-inputs
-       (("rust-autocfg" ,rust-autocfg-0.1))))
+        ("rust-rand-core" ,rust-rand-core-0.5))))
     (home-page "https://crates.io/crates/rand-chacha")
     (synopsis "ChaCha random number generator")
     (description "ChaCha random number generator.")