summary refs log tree commit diff
diff options
context:
space:
mode:
authorDanny Milosavljevic <dannym@scratchpost.org>2023-02-02 21:53:23 +0100
committerDanny Milosavljevic <dannym@scratchpost.org>2023-02-02 21:53:23 +0100
commit74f15a002cf2979f3268afeed61aa1aef09ea4fa (patch)
tree004ef60b99b9178ba35f61fd4851db0d65b47d8b
parentd081dd1ca1f43fb8a1cccadb31e684ecdcb5aa29 (diff)
downloadguix-74f15a002cf2979f3268afeed61aa1aef09ea4fa.tar.gz
gnu: nvc: Update to 1.8.1.
* gnu/packages/fpga.scm (nvc): Update to 1.8.1.
[inputs]: Add libffi.
-rw-r--r--gnu/packages/fpga.scm7
1 files changed, 4 insertions, 3 deletions
diff --git a/gnu/packages/fpga.scm b/gnu/packages/fpga.scm
index acce5f8f82..a516e4dc7e 100644
--- a/gnu/packages/fpga.scm
+++ b/gnu/packages/fpga.scm
@@ -433,7 +433,7 @@ a hardware description and verification language.")
 (define-public nvc
   (package
     (name "nvc")
-    (version "1.7.2")
+    (version "1.8.1")
     (source (origin
               (method git-fetch)
               (uri (git-reference
@@ -442,7 +442,7 @@ a hardware description and verification language.")
               (file-name (string-append name "-" version "-checkout"))
               (sha256
                (base32
-                "01b0yhr0fw59nxwi4pz04mp9b71mg6s7zaysp0r8h0m2nd5pbpgc"))))
+                "03dnn77n50b5n06gd81hh36gh0h2nc266yzwl70qjlb00qs8cf7p"))))
     (build-system gnu-build-system)
     (arguments
      `(#:out-of-source? #t
@@ -464,7 +464,8 @@ a hardware description and verification language.")
            check)) ; for the tests
     (inputs
      (list elfutils
-           llvm-9))
+           llvm-9
+           libffi))
     (synopsis "VHDL compiler and simulator")
     (description "This package provides a VHDL compiler and simulator.")
     (home-page "https://www.nickg.me.uk/nvc/")