summary refs log tree commit diff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2019-09-08 11:17:53 +0300
committerEfraim Flashner <efraim@flashner.co.il>2019-09-08 11:18:39 +0300
commit799d8d3ca616c0a85d8f0b6e7f5e12898db94714 (patch)
treea6557bb1fbe8498473572f61360edc3d5bb0e873
parente0819e5ca2d59d87ba6c16a6149e7b18faf60543 (diff)
downloadguix-799d8d3ca616c0a85d8f0b6e7f5e12898db94714.tar.gz
gnu: haskell-xyz.scm: Correctly hide packages.
* gnu/packages/haskell-xyz.scm (ghc-attoparsec-bootstrap,
ghc-integer-logarithms-bootstrap, ghc-scientific-bootstrap,
ghc-semigroups-bootstrap, ghc-unordered-containers-bootstrap,
ghc-wcwidth-bootstrap)[properties]: Fix typo, make 'hidden?' a tuple.
-rw-r--r--gnu/packages/haskell-xyz.scm14
1 files changed, 7 insertions, 7 deletions
diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index 940fbe8a6c..ee26c1a25a 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -5,7 +5,7 @@
 ;;; Copyright © 2015, 2019 Eric Bavier <bavier@member.fsf.org>
 ;;; Copyright © 2016, 2018, 2019 Ludovic Courtès <ludo@gnu.org>
 ;;; Copyright © 2016, 2017 ng0 <ng0@n0.is>
-;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2016, 2019 Efraim Flashner <efraim@flashner.co.il>
 ;;; Copyright © 2015, 2016, 2017, 2018, 2019 Ricardo Wurmus <rekado@elephly.net>
 ;;; Copyright © 2016, 2017 David Craven <david@craven.ch>
 ;;; Copyright © 2017 Danny Milosavljevic <dannym@scratchpost.org>
@@ -463,7 +463,7 @@ complicated text/binary file formats.")
     (inputs
      `(("ghc-scientific" ,ghc-scientific-bootstrap)))
     (native-inputs '())
-    (properties '(hidden? #t))))
+    (properties '((hidden? #t)))))
 
 (define-public ghc-attoparsec-iso8601
   (package
@@ -5201,7 +5201,7 @@ in migrated modules.")
     (name "ghc-integer-logarithms-bootstrap")
     (arguments `(#:tests? #f))
     (native-inputs '())
-    (properties '(hidden? #t))))
+    (properties '((hidden? #t)))))
 
 (define-public ghc-interpolate
   (package
@@ -8667,7 +8667,7 @@ notation}.")
        ("ghc-hashable" ,ghc-hashable)
        ("ghc-primitive" ,ghc-primitive)))
     (native-inputs '())
-    (properties '(hidden? #t))))
+    (properties '((hidden? #t)))))
 
 (define-public ghc-sdl
   (package
@@ -8951,7 +8951,7 @@ semigroup.")
        ("ghc-tagged" ,ghc-tagged)
        ("ghc-unordered-containers" ,ghc-unordered-containers-bootstrap)
        ("ghc-hashable" ,ghc-hashable-bootstrap)))
-    (properties '(hidden? #t))))
+    (properties '((hidden? #t)))))
 
 (define-public ghc-setenv
   (package
@@ -10781,7 +10781,7 @@ and high speed.")
     (arguments `(#:tests? #f))
     (inputs
      `(("ghc-hashable" ,ghc-hashable-bootstrap)))
-    (properties '(hidden? #t))))
+    (properties '((hidden? #t)))))
 
 (define-public ghc-unsafe
   (package
@@ -11322,7 +11322,7 @@ widths to the Char type.")
      `(("ghc-setlocale" ,ghc-setlocale)
        ("ghc-utf8-string" ,ghc-utf8-string)
        ("ghc-attoparsec" ,ghc-attoparsec-bootstrap)))
-    (properties '(hidden? #t))))
+    (properties '((hidden? #t)))))
 
 (define-public ghc-weigh
   (package