summary refs log tree commit diff
diff options
context:
space:
mode:
authorMatthew James Kraai <kraai@ftbfs.org>2022-10-20 20:16:00 -0700
committerLudovic Courtès <ludo@gnu.org>2022-11-18 15:44:39 +0100
commit856b67f3021d1c764ef30b5a166edfb4244d9cad (patch)
tree4c73f16faeb1c35a21c9369e53290423501e46ce
parentfc2b9522057681330d3b507aa69c9aa3b3b8f3e6 (diff)
downloadguix-856b67f3021d1c764ef30b5a166edfb4244d9cad.tar.gz
gnu: s3cmd: Fix program name in output.
* gnu/packages/python-xyz.scm (s3cmd)[arguments]: Add a new 'hide-wrapping
phase.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/python-xyz.scm9
1 files changed, 9 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index e3d1ac05fa..c5ab9280eb 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -16395,6 +16395,15 @@ the same purpose: to provide Python bindings for libmagic.")
        (sha256
         (base32 "0rdgwwmmp8mdxc84bxq6k9a7v7z2qgc3df47djzs2b84gw81dglx"))))
     (build-system python-build-system)
+    (arguments
+     (list #:phases
+           #~(modify-phases %standard-phases
+               (add-after 'unpack 'hide-wrapping
+                 (lambda _
+                   (substitute* "S3/MultiPart.py"
+                     (("sys\\.argv\\[0\\]") "\"s3cmd\""))
+                   (substitute* "s3cmd"
+                     (("optparser\\.get_prog_name\\(\\)") "\"s3cmd\"")))))))
     (inputs
      (list python-dateutil
            python-magic))