summary refs log tree commit diff
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-06-25 21:08:04 +0200
committerMarius Bakke <marius@gnu.org>2022-06-26 12:06:28 +0200
commit875c8ee0072506bcd3e3cd7848fe8377151bd81b (patch)
tree4c037a0cb4d42ccf0be2bb4d8cf6d7f8c47f2943
parentca88640a451e1cdb2d97bebee47f619605e7a389 (diff)
downloadguix-875c8ee0072506bcd3e3cd7848fe8377151bd81b.tar.gz
gnu: expat: Update to 2.4.8.
* gnu/packages/xml.scm (expat): Update to 2.4.8.
[replacement]: Remove.
(expat/fixed): Remove variable.
-rw-r--r--gnu/packages/xml.scm22
1 files changed, 2 insertions, 20 deletions
diff --git a/gnu/packages/xml.scm b/gnu/packages/xml.scm
index 0ae51d2e2b..c8df031cec 100644
--- a/gnu/packages/xml.scm
+++ b/gnu/packages/xml.scm
@@ -121,8 +121,7 @@ the entire document.")
 (define-public expat
   (package
     (name "expat")
-    (version "2.4.1")
-    (replacement expat/fixed)
+    (version "2.4.8")
     (source (let ((dot->underscore (lambda (c) (if (char=? #\. c) #\_ c))))
               (origin
                 (method url-fetch)
@@ -134,7 +133,7 @@ the entire document.")
                             "/expat-" version ".tar.xz")))
                 (sha256
                  (base32
-                  "0spvyb9d3hijs4ys3x64cfmilsynl8kv6clfahv8d4lvp86js0yg")))))
+                  "09dgviwz939pms4v1syl68p5pia9hb7xxsmg406kx7kl9f88z6zp")))))
     (build-system gnu-build-system)
     (arguments
      '(#:phases (modify-phases %standard-phases
@@ -158,23 +157,6 @@ stream-oriented parser in which an application registers handlers for
 things the parser might find in the XML document (like start tags).")
     (license license:expat)))
 
-(define expat/fixed
-  (package
-    (inherit expat)
-    (version "2.4.7")
-    (source (let ((dot->underscore (lambda (c) (if (char=? #\. c) #\_ c))))
-              (origin
-                (method url-fetch)
-                (uri (list (string-append "mirror://sourceforge/expat/expat/"
-                                          version "/expat-" version ".tar.xz")
-                           (string-append
-                            "https://github.com/libexpat/libexpat/releases/download/R_"
-                            (string-map dot->underscore version)
-                            "/expat-" version ".tar.xz")))
-                (sha256
-                 (base32
-                  "0zbss0dssn17mjmvk17qfi5cmvm0lcyzs62cwvqr219hhl864xcq")))))))
-
 (define-public libebml
   (package
     (name "libebml")