summary refs log tree commit diff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-04-15 22:06:44 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-04-19 20:12:11 -0400
commit87d9374807d49e8cc3ac35ac1365078e433180c9 (patch)
tree59c4298b3d092fc39fc945026a2d0f9623debe7b
parent19c178e35f40e4da0e4f86335bcc00c9a6d5f734 (diff)
downloadguix-87d9374807d49e8cc3ac35ac1365078e433180c9.tar.gz
gnu: python-tomli: Update to 2.0.1.
* gnu/packages/python-build.scm (python-tomli): Update to 2.0.1.
[build-system]: Use pyproject-build-system.
[arguments]: Remove build and install phase overrides.  Add add-self-to-path.
[native-inputs]: Remove python-pypa-build and input labels.
-rw-r--r--gnu/packages/python-build.scm25
1 files changed, 7 insertions, 18 deletions
diff --git a/gnu/packages/python-build.scm b/gnu/packages/python-build.scm
index c5438b5e78..61e035d384 100644
--- a/gnu/packages/python-build.scm
+++ b/gnu/packages/python-build.scm
@@ -179,34 +179,23 @@ Python file, so it can be easily copied into your project.")
 (define-public python-tomli
   (package
     (name "python-tomli")
-    (version "2.0.0")
+    (version "2.0.1")
     (source
      (origin
        (method url-fetch)
        (uri (pypi-uri "tomli" version))
        (sha256
-        (base32 "1q8lrh9ypa6zpgbc5f7z23p7phzblp4vpxdrpfr1wajhb17w74n2"))))
-    (build-system python-build-system)
+        (base32 "0kwazq3i18rphcr8gak4fgzdcj5w5bbn4k4j2l6ma32gj496qlny"))))
+    (build-system pyproject-build-system)
     (arguments
      `(#:tests? #f                      ;disabled to avoid extra dependencies
        #:phases
        (modify-phases %standard-phases
-         (replace 'build
+         (add-before 'build 'add-self-to-path
            (lambda _
-             (setenv "PYTHONPATH" (string-append (getcwd) ":"
-                                                 (getenv "GUIX_PYTHONPATH")))
-             (invoke "python" "-m" "build" "--wheel" "--no-isolation"
-                     "--skip-dependency-check")))
-         (replace 'install
-           (lambda* (#:key outputs #:allow-other-keys)
-             (let ((out (assoc-ref outputs "out"))
-                   (whl (car (find-files "dist" "\\.whl$"))))
-               (invoke "pip" "--no-cache-dir" "--no-input"
-                       "install" "--no-deps" "--prefix" out whl)))))))
-    (native-inputs
-     `(("python-flit-core-bootstrap" ,python-flit-core-bootstrap)
-       ("python-pypa-build" ,python-pypa-build)
-       ("python-six", python-six-bootstrap)))
+             ;; The build system of tomli requires... tomli.
+             (setenv "PYTHONPATH" "src"))))))
+    (native-inputs (list python-flit-core-bootstrap python-six-bootstrap))
     (home-page "https://github.com/hukkin/tomli")
     (synopsis "Small and fast TOML parser")
     (description "Tomli is a minimal TOML parser that is fully compatible with