summary refs log tree commit diff
diff options
context:
space:
mode:
authorPetr Hodina <phodina@protonmail.com>2022-08-26 06:01:45 +0200
committerMarius Bakke <marius@gnu.org>2022-11-21 22:01:09 +0100
commit8ca39d7a125254a8bb6740bf29eb1404014b14ca (patch)
tree89e2ade013c0d752ba2f9accc147f72eaa2eea7d
parent605a6c87cb951aaad97e30b39fc8ff8bbf5f3531 (diff)
downloadguix-8ca39d7a125254a8bb6740bf29eb1404014b14ca.tar.gz
gnu: Add kgamma.
* gnu/packages/kde-plasma.scm (kgamma): New variable.

Signed-off-by: Marius Bakke <marius@gnu.org>
-rw-r--r--gnu/packages/kde-plasma.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/kde-plasma.scm b/gnu/packages/kde-plasma.scm
index 14733c7c0a..8b3e525b07 100644
--- a/gnu/packages/kde-plasma.scm
+++ b/gnu/packages/kde-plasma.scm
@@ -138,6 +138,32 @@ These window decorations can be used by for example an X11 based window
 manager which re-parents a Client window to a window decoration frame.")
     (license license:lgpl3+)))
 
+(define-public kgamma
+  (package
+    (name "kgamma")
+    (version "5.25.5")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "mirror://kde/stable/plasma/"
+                                  version "/" name "5-"
+                                  version ".tar.xz"))
+              (sha256
+               (base32
+                "1c305bs50km7bsn0phz7yj4x2168sxwsw9zxbpcgw4q3r53c0ywz"))))
+    (build-system qt-build-system)
+    (native-inputs (list extra-cmake-modules))
+    (inputs (list kauth
+                  kcoreaddons
+                  kconfig
+                  kconfigwidgets
+                  kdoctools
+                  ki18n))
+    (synopsis "Adjust monitor gamma settings")
+    (description
+     "This package provides a tool to adjust your monitor gamma settings.")
+    (home-page "https://invent.kde.org/plasma/kgamma5")
+    (license license:gpl2+)))
+
 (define-public ksshaskpass
   (package
     (name "ksshaskpass")