summary refs log tree commit diff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-04-05 04:14:30 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2019-04-10 20:54:03 +0200
commit8e71904ad145a107b08ca12c2860d95fd48c6674 (patch)
tree17c341b9656484dc9165820c3c2133b459af7f00
parentd8e9ae6467ff337008ca92e73771ca279ccb7f88 (diff)
downloadguix-8e71904ad145a107b08ca12c2860d95fd48c6674.tar.gz
gnu: emacs-highlight-symbol: Don't use unstable tarball.
* gnu/packages/emacs-xyz.scm (emacs-highlight-symbol)[source]: Use GIT-FETCH and
GIT-FILE-NAME.
-rw-r--r--gnu/packages/emacs-xyz.scm18
1 files changed, 9 insertions, 9 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 38e6d5e9c3..a51b0711fd 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -3817,15 +3817,15 @@ well as completely new features.")
   (package
     (name "emacs-highlight-symbol")
     (version "1.3")
-    (source (origin
-              (method url-fetch)
-              (uri (string-append
-                    "https://github.com/nschum/highlight-symbol.el/archive/"
-                    version ".tar.gz"))
-              (file-name (string-append name "-" version ".tar.gz"))
-              (sha256
-               (base32
-                "1n7k1qns0fn0jsyc0hrjac5nzk21xw48yc30vyrhwvc51h0b9g90"))))
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/nschum/highlight-symbol.el.git")
+             (commit version)))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "09z13kv2g21kjjkkm3iyaz93sdjmdy2d563r8n7r7ng94acrn7f6"))))
     (build-system emacs-build-system)
     (home-page "https://nschum.de/src/emacs/highlight-symbol")
     (synopsis "Automatic and manual symbol highlighting for Emacs")