summary refs log tree commit diff
diff options
context:
space:
mode:
authorRaimon Grau <raimonster@gmail.com>2014-02-06 01:43:31 +0100
committerLudovic Courtès <ludo@gnu.org>2014-02-06 19:04:02 +0100
commit924cd631168ba6d03e7aee57f3e02d4c0959f9dd (patch)
tree65245bc9882e25bedba146deccd70d9423faa959
parent3600420e3e4bfc105e3d01474688ab10a7eb37a6 (diff)
downloadguix-924cd631168ba6d03e7aee57f3e02d4c0959f9dd.tar.gz
gnu: Add luajit
* gnu/packages/lua.scm (luajit): New variable.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/lua.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/lua.scm b/gnu/packages/lua.scm
index 14fc28ced0..81caa263ad 100644
--- a/gnu/packages/lua.scm
+++ b/gnu/packages/lua.scm
@@ -1,5 +1,6 @@
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2013 Cyril Roelandt <tipecaml@gmail.com>
+;;; Copyright © 2014 Raimon Grau <raimonster@gmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -61,3 +62,27 @@ runs by interpreting bytecode for a register-based virtual machine, and has
 automatic memory management with incremental garbage collection, making it ideal
 for configuration, scripting, and rapid prototyping.")
     (license x11)))
+
+(define-public luajit
+  (package
+    (name "luajit")
+    (version "2.0.2")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "http://luajit.org/download/LuaJIT-"
+                                  version ".tar.gz"))
+              (sha256
+               (base32 "0f3cykihfdn3gi6na9p0xjd4jnv26z18m441n5vyg42q9abh4ln0"))))
+    (build-system gnu-build-system)
+    (arguments
+     '(#:tests? #f                      ;luajit is distributed without tests
+       #:phases (alist-delete 'configure %standard-phases)
+       #:make-flags (list (string-append "PREFIX=" (assoc-ref %outputs "out")))))
+    (home-page "http://www.luajit.org/")
+    (synopsis "Just in time compiler for Lua programming language version 5.1")
+    (description
+     "LuaJIT is a Just-In-Time Compiler (JIT) for the Lua
+programming language.  Lua is a powerful, dynamic and light-weight programming
+language.  It may be embedded or used as a general-purpose, stand-alone
+language.")
+    (license x11)))