summary refs log tree commit diff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2017-08-28 17:14:16 +0300
committerEfraim Flashner <efraim@flashner.co.il>2017-08-28 17:25:00 +0300
commit92cc6a5801f66425bcad1e418b401f99b2dc7f90 (patch)
treef341fba213a8e7b6eb0913afd27857b019f53321
parente184de574843e0f374ecae975b3459c52abf0f8f (diff)
downloadguix-92cc6a5801f66425bcad1e418b401f99b2dc7f90.tar.gz
gnu: gnupg: Clean up arguments.
* gnu/packages/gnupg.scm (gnupg)[arguments]: Shorten the
'patch-test-paths phase.
-rw-r--r--gnu/packages/gnupg.scm32
1 files changed, 12 insertions, 20 deletions
diff --git a/gnu/packages/gnupg.scm b/gnu/packages/gnupg.scm
index 872e98f44e..c442ce8aed 100644
--- a/gnu/packages/gnupg.scm
+++ b/gnu/packages/gnupg.scm
@@ -250,26 +250,18 @@ compatible to GNU Pth.")
                (string-append (getcwd) "/tests/gpgscm/gpgscm")))
             #t))
         (add-before 'build 'patch-test-paths
-          (lambda* (#:key inputs #:allow-other-keys)
-            (let* ((coreutils (assoc-ref inputs "coreutils"))
-                   (cat (string-append coreutils "/bin/cat"))
-                   (pwd (string-append coreutils "/bin/pwd"))
-                   (true (string-append coreutils "/bin/true"))
-                   (false (string-append coreutils "/bin/false")))
-              (substitute* '("tests/inittests"
-                             "tests/pkits/inittests"
-                             "tests/Makefile"
-                             "tests/pkits/common.sh"
-                             "tests/pkits/Makefile"
-                            )
-               (("/bin/pwd") pwd))
-              (substitute* "common/t-exectool.c"
-                (("/bin/cat") cat))
-              (substitute* "common/t-exectool.c"
-                (("/bin/true") true))
-              (substitute* "common/t-exectool.c"
-                (("/bin/false") false))
-              #t))))))
+          (lambda _
+            (substitute* '("tests/inittests"
+                           "tests/pkits/inittests"
+                           "tests/Makefile"
+                           "tests/pkits/common.sh"
+                           "tests/pkits/Makefile")
+             (("/bin/pwd") (which "pwd")))
+            (substitute* "common/t-exectool.c"
+              (("/bin/cat") (which "cat"))
+              (("/bin/true") (which "true"))
+              (("/bin/false") (which "false")))
+            #t)))))
     (home-page "https://gnupg.org/")
     (synopsis "GNU Privacy Guard")
     (description