summary refs log tree commit diff
diff options
context:
space:
mode:
authorFidel Ramos <f@fidelramos.net>2022-11-20 10:25:56 +0000
committerAndrew Tropin <andrew@trop.in>2022-11-21 09:00:25 +0400
commit97bbdedfd316694a2f7ed17d8b31101c27329c80 (patch)
tree9e6b06fa4a966b53552ba9885e7c4d3ac98757d6
parent99ba4ddb03b396f56764a25317f40d4501380704 (diff)
downloadguix-97bbdedfd316694a2f7ed17d8b31101c27329c80.tar.gz
gnu: Add emacs-dirvish.
* gnu/packages/emacs-xyz.scm (emacs-dirvish): New variable.

Signed-off-by: Andrew Tropin <andrew@trop.in>
-rw-r--r--gnu/packages/emacs-xyz.scm36
1 files changed, 36 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 5c1138e954..a92ab71a97 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -17103,6 +17103,42 @@ additions:
 or @code{treemacs}, but leveraging @code{Dired} to do the job of display.")
     (license license:gpl3+)))
 
+(define-public emacs-dirvish
+  (package
+    (name "emacs-dirvish")
+    (version "2.0.53")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/alexluigit/dirvish")
+                    (commit "c535e2147171be5506f4ff34e862bacbfb3de768")))
+              (sha256
+               (base32
+                "1nmp5ci4dvcpih6phfhk66s98lf8b49qd35ymy29kqkf5v4cnwga"))
+              (file-name (git-file-name name version))))
+    (build-system emacs-build-system)
+    (propagated-inputs (list emacs-transient))
+    (arguments
+     (list
+      #:phases
+      #~(modify-phases %standard-phases
+          ;; Move the extensions source files to the top level, which
+          ;; is included in the EMACSLOADPATH.
+          (add-after 'unpack 'move-source-files
+            (lambda _
+              (let ((el-files (find-files "./extensions" ".*\\.el$")))
+                (for-each (lambda (f)
+                            (rename-file f (basename f)))
+                          el-files)))))))
+    (home-page "https://github.com/alexluigit/dirvish")
+    (synopsis "Improved version of the Emacs package Dired")
+    (description
+     "Dirvish is an improved version of the Emacs inbuilt package Dired.  It
+not only gives Dired an appealing and highly customizable user interface, but
+also comes together with almost all possible parts required for full usability
+as a modern file manager.")
+    (license license:gpl3+)))
+
 (define-public emacs-which-key
   (package
     (name "emacs-which-key")