summary refs log tree commit diff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2020-06-07 18:42:49 +0300
committerEfraim Flashner <efraim@flashner.co.il>2020-06-07 22:27:36 +0300
commit9b5e7d01afc0ca295ccba231b002f5314f5ef9bd (patch)
treea9a402f41e9ae78a5ea45a57da5adb10092ad489
parenta6e2c477c5ebe28a64d4c5292a783631563fd36e (diff)
downloadguix-9b5e7d01afc0ca295ccba231b002f5314f5ef9bd.tar.gz
gnu: Add vim-dispatch.
* gnu/packages/vim.scm (vim-dispatch): New variable.
-rw-r--r--gnu/packages/vim.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/vim.scm b/gnu/packages/vim.scm
index deea538622..2d9447d211 100644
--- a/gnu/packages/vim.scm
+++ b/gnu/packages/vim.scm
@@ -872,3 +872,31 @@ through its msgpack-rpc API.")
 NeoVim) to enable you to run shell commands in background and read output in the
 quickfix window in realtime.")
     (license license:expat)))
+
+(define-public vim-dispatch
+  (package
+    (name "vim-dispatch")
+    (version "1.8")
+    (source
+      (origin
+        (method git-fetch)
+        (uri (git-reference
+               (url "https://github.com/tpope/vim-dispatch")
+               (commit (string-append "v" version))))
+        (file-name (git-file-name name version))
+        (sha256
+         (base32
+          "1m8b5mn2zqlphzs6xfwykwmghf6p0wabrhpjmh7vav35jgcxc4wl"))))
+    (build-system copy-build-system)
+    (arguments
+     '(#:install-plan
+       '(("autoload" "share/vim/vimfiles/")
+         ("doc" "share/vim/vimfiles/")
+         ("plugin" "share/vim/vimfiles/"))))
+    (home-page "https://github.com/tpope/vim-dispatch")
+    (synopsis "Asynchronous build and test dispatcher")
+    (description "Leverage the power of Vim's compiler plugins without being
+bound by synchronicity.  Kick off builds and test suites using one of several
+asynchronous adapters (including tmux, screen, and a headless mode), and when
+the job completes, errors will be loaded and parsed automatically.")
+    (license license:vim)))