summary refs log tree commit diff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-05-22 17:16:34 +0300
committerEfraim Flashner <efraim@flashner.co.il>2023-07-18 20:56:03 +0300
commit9c9a77baa9e1750dc436b9537f089ab9c7e05342 (patch)
treef432a71717c50b5372057a89dfee269df2189972
parenta25aef5e102f5768f71e9241f8b8bff1f5e6fee6 (diff)
downloadguix-9c9a77baa9e1750dc436b9537f089ab9c7e05342.tar.gz
gnu: Add rust-state-0.5.
* gnu/packages/crates-io.scm (rust-state-0.5): New variable.
(rust-state-0.4): Inherit from rust-state-0.5.
-rw-r--r--gnu/packages/crates-io.scm34
1 files changed, 26 insertions, 8 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index a363fe5349..ae0be74b01 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -60572,8 +60572,33 @@ deeply recursive algorithms that may accidentally blow the stack.")
     (description "New standard library, old compiler.")
     (license (list license:expat license:asl2.0))))
 
+(define-public rust-state-0.5
+  (package
+    (name "rust-state")
+    (version "0.5.3")
+    (source (origin
+              (method url-fetch)
+              (uri (crate-uri "state" version))
+              (file-name (string-append name "-" version ".tar.gz"))
+              (sha256
+               (base32
+                "0fzji31ijbkimbzdy4dln9mp5xp7lm1a0dnqxv4n10hywphnds6v"))))
+    (build-system cargo-build-system)
+    (arguments
+     `(#:cargo-inputs
+       (("rust-loom" ,rust-loom-0.5))
+       #:cargo-development-inputs
+       (("rust-static-assertions" ,rust-static-assertions-1))))
+    (home-page "https://github.com/SergioBenitez/state")
+    (synopsis "Library for safe global and thread-local state management")
+    (description
+     "This package provides a library for safe global and thread-local state
+management.")
+    (license (list license:expat license:asl2.0))))
+
 (define-public rust-state-0.4
   (package
+    (inherit rust-state-0.5)
     (name "rust-state")
     (version "0.4.2")
     (source
@@ -60583,17 +60608,10 @@ deeply recursive algorithms that may accidentally blow the stack.")
        (file-name (string-append name "-" version ".tar.gz"))
        (sha256
         (base32 "10v4k9bgjryc9m40c8nnhyrby2ngkhpx841p3k4halgxlp8af59h"))))
-    (build-system cargo-build-system)
     (arguments
      `(#:skip-build? #t
        #:cargo-inputs
-       (("rust-lazy-static" ,rust-lazy-static-1))))
-    (home-page "https://github.com/SergioBenitez/state")
-    (synopsis "Library for safe global and thread-local state management")
-    (description
-     "This package provides a library for safe global and thread-local state
-management.")
-    (license (list license:expat license:asl2.0))))
+       (("rust-lazy-static" ,rust-lazy-static-1))))))
 
 (define-public rust-static-assertions-1
   (package