summary refs log tree commit diff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2015-09-09 22:55:33 +0200
committerLudovic Courtès <ludo@gnu.org>2015-09-09 23:29:50 +0200
commit9d9847e1538096ff9fa1a1f4a9fe633a9a13922e (patch)
tree6d6378a5bf56f3fda374decb1ae01988cb6c5bb7
parent5625adfcccf1bcd81a1948650c1d8fd53eb789dc (diff)
downloadguix-9d9847e1538096ff9fa1a1f4a9fe633a9a13922e.tar.gz
gnu: curl: Move man3 pages to "doc" output.
* gnu/packages/curl.scm (curl)[outputs]: New field.
  [arguments]: Add 'move-man3-pages' phase.
-rw-r--r--gnu/packages/curl.scm13
1 files changed, 13 insertions, 0 deletions
diff --git a/gnu/packages/curl.scm b/gnu/packages/curl.scm
index 55a5d1e782..f7c9f083b7 100644
--- a/gnu/packages/curl.scm
+++ b/gnu/packages/curl.scm
@@ -2,6 +2,7 @@
 ;;; Copyright © 2013, 2014 Andreas Enge <andreas@enge.fr>
 ;;; Copyright © 2015 Mark H Weaver <mhw@netris.org>
 ;;; Copyright © 2015 Tomáš Čech <sleep_walker@suse.cz>
+;;; Copyright © 2015 Ludovic Courtès <ludo@gnu.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -47,6 +48,8 @@
              (base32
               "0gjnaav9vmwwwza451na1643br7i0kxgd4002pwqh3xk5ywvdap7"))))
    (build-system gnu-build-system)
+   (outputs '("out"
+              "doc"))                             ;1.2 MiB of man3 pages
    (inputs `(("gnutls" ,gnutls)
              ("gss" ,gss)
              ("libidn" ,libidn)
@@ -64,6 +67,16 @@
       ;; Add a phase to patch '/bin/sh' occurances in tests/runtests.pl
       #:phases
       (modify-phases %standard-phases
+        (add-after
+         'install 'move-man3-pages
+         (lambda* (#:key outputs #:allow-other-keys)
+           ;; Move section 3 man pages to "doc".
+           (let ((out (assoc-ref outputs "out"))
+                 (doc (assoc-ref outputs "doc")))
+             (mkdir-p (string-append doc "/share/man"))
+             (rename-file (string-append out "/share/man/man3")
+                          (string-append doc "/share/man/man3"))
+             #t)))
         (replace
          'check
          (lambda _