summary refs log tree commit diff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-03-31 08:35:01 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-03-31 08:35:01 -0400
commit9eafe47e39e8f1a30fd4cd96beba024f4c67bdf5 (patch)
treec519b41179bffd14535c911d46a66dd4284e6af7
parent4876226dd55a9a4df1cea4a80fcb0dcb7052a966 (diff)
downloadguix-9eafe47e39e8f1a30fd4cd96beba024f4c67bdf5.tar.gz
gnu: ruby-activesupport: Skip a failing test on i686-linux.
* gnu/packages/rails.scm (ruby-activesupport)
[arguments]: Skip the test_iso8601_output_and_reparsing test when building for
i686-linux.
-rw-r--r--gnu/packages/rails.scm6
1 files changed, 6 insertions, 0 deletions
diff --git a/gnu/packages/rails.scm b/gnu/packages/rails.scm
index c830620b82..b1abb65a6d 100644
--- a/gnu/packages/rails.scm
+++ b/gnu/packages/rails.scm
@@ -81,6 +81,12 @@
                  "")
                 ((".*behaviors/encoded_key_cache_behavior.*")
                  ""))
+              (when #$(target-x86-32?)
+                ;; This test fails on i686 (see:
+                ;; https://github.com/rails/rails/issues/47832).
+                (substitute* "test/core_ext/duration_test.rb"
+                  (("def test_iso8601_output_and_reparsing.*" all)
+                   (string-append all "    skip('fails on i686')\n"))))
               (delete-file "test/evented_file_update_checker_test.rb")
               ;; These tests require cache_store_behavior, disabled above.
               (delete-file "test/cache/stores/file_store_test.rb")