summary refs log tree commit diff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-12-13 23:04:59 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-12-14 11:05:52 -0500
commit9ebeba825448c72ac13c37b4d9ddd6275bc801fb (patch)
tree6da1d507b67ede753a2cf64b3eef5adb20fe99a5
parent41e61e4fed8d2818549721ddc479f1dd4b616ead (diff)
downloadguix-9ebeba825448c72ac13c37b4d9ddd6275bc801fb.tar.gz
gnu: icecat-source: Enable xz parallel compression.
* gnu/packages/gnuzilla.scm (icecat-source): Set XZ_DEFAULTS to
%xz-parallel-args to enable parallel compression and hasten the build.  Remove
trailing #t.
-rw-r--r--gnu/packages/gnuzilla.scm5
1 files changed, 2 insertions, 3 deletions
diff --git a/gnu/packages/gnuzilla.scm b/gnu/packages/gnuzilla.scm
index 26fd5f95eb..27a9d099ce 100644
--- a/gnu/packages/gnuzilla.scm
+++ b/gnu/packages/gnuzilla.scm
@@ -873,6 +873,7 @@ in C/C++.")
 
                 (format #t "Packing IceCat source tarball...~%")
                 (force-output)
+                (setenv "XZ_DEFAULTS" (string-join (%xz-parallel-args)))
                 (invoke "tar" "cfa" #$output
                         ;; Avoid non-determinism in the archive.  We set the
                         ;; mtime of files in the archive to early 1980 because
@@ -883,9 +884,7 @@ in C/C++.")
                         "--owner=root:0"
                         "--group=root:0"
                         "--sort=name"
-                        icecat-dir)
-
-                #t))))))))
+                        icecat-dir)))))))))
 
 (define-public icecat
   (package