summary refs log tree commit diff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-07-13 22:21:11 +0300
committerEfraim Flashner <efraim@flashner.co.il>2023-07-18 20:56:30 +0300
commita07af751bd0d03c741c2ef6afafd757f01045885 (patch)
tree4bcb1cee1b371320390b7f88b0cdd475fad6f4bd
parent689bdf853b79b2111e1c1894075bccda9bdf78a7 (diff)
downloadguix-a07af751bd0d03c741c2ef6afafd757f01045885.tar.gz
gnu: Add rust-python-pkginfo-0.5.
* gnu/packages/crates-io.scm (rust-python-pkginfo-0.5): New variable.
-rw-r--r--gnu/packages/crates-io.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 2ce0c3629c..b7b553d446 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -49893,6 +49893,37 @@ Python code from a Rust binary is also supported.")
     (description "This package provides a pyproject.toml parser in Rust.")
     (license license:expat)))
 
+(define-public rust-python-pkginfo-0.5
+  (package
+    (name "rust-python-pkginfo")
+    (version "0.5.6")
+    (source (origin
+              (method url-fetch)
+              (uri (crate-uri "python-pkginfo" version))
+              (file-name (string-append name "-" version ".tar.gz"))
+              (sha256
+               (base32
+                "03hvc5h10vicfjql9dw46w0xcwq2gjm9sfbfmr13rglz1z68hfg2"))))
+    (build-system cargo-build-system)
+    (arguments
+     `(#:cargo-inputs
+       (("rust-bzip2" ,rust-bzip2-0.4)
+        ("rust-flate2" ,rust-flate2-1)
+        ("rust-fs-err" ,rust-fs-err-2)
+        ("rust-mailparse" ,rust-mailparse-0.14)
+        ("rust-rfc2047-decoder" ,rust-rfc2047-decoder-0.2)
+        ("rust-serde" ,rust-serde-1)
+        ("rust-tar" ,rust-tar-0.4)
+        ("rust-thiserror" ,rust-thiserror-1)
+        ("rust-xz" ,rust-xz-0.1)
+        ("rust-zip" ,rust-zip-0.6))
+       #:cargo-development-inputs (("rust-serde-json" ,rust-serde-json-1))))
+    (home-page "https://github.com/PyO3/python-pkginfo-rs")
+    (synopsis "Parse Python package metadata from sdist and bdists")
+    (description
+     "Parse Python package metadata from sdist and bdists and etc.")
+    (license license:expat)))
+
 (define-public rust-python3-dll-a-0.2
   (package
     (name "rust-python3-dll-a")