summary refs log tree commit diff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-10-26 09:01:27 +0300
committerEfraim Flashner <efraim@flashner.co.il>2021-10-26 09:01:27 +0300
commita41f93c39d03143ce9007ad278a04fa30498bc0b (patch)
treeb4650996c0f41fb5d9c5fbda90f5e8c49392217e
parent1aad42e24cc927cea34dd8e4ef49f8afdbd102e8 (diff)
downloadguix-a41f93c39d03143ce9007ad278a04fa30498bc0b.tar.gz
gnu: python-joblib: Run test suite sequentially.
* gnu/packages/python-xyz.scm (python-joblib)[arguments]: Adjust custom
'check phase to run the test suite sequentially.
-rw-r--r--gnu/packages/python-xyz.scm1
1 files changed, 1 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index cc724ed153..da3402477e 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -4010,6 +4010,7 @@ logic-free templating system Mustache.")
          (replace 'check
            (lambda* (#:key tests? #:allow-other-keys)
              (when tests?
+               (setenv "JOBLIB_MULTIPROCESSING" "0")
                (invoke "pytest" "-v" "joblib")))))))
     (native-inputs
      `(("python-pytest" ,python-pytest)))