summary refs log tree commit diff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2022-01-11 10:34:16 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2022-01-11 10:34:16 +0100
commita7478b1ca0f4fbd38d84d9dcd809a6a4089865cc (patch)
tree649bdfa9a939f3e471442fa23212efa67eae22a5
parent509ef2125de8615c81b7272e4d7779b8d24e0a7b (diff)
downloadguix-a7478b1ca0f4fbd38d84d9dcd809a6a4089865cc.tar.gz
gnu: notmuch: Simplify inputs.
* gnu/packages/mail.scm (notmuch)[native-inputs]: Remove labels.
-rw-r--r--gnu/packages/mail.scm27
1 files changed, 13 insertions, 14 deletions
diff --git a/gnu/packages/mail.scm b/gnu/packages/mail.scm
index 766037693c..fc41034494 100644
--- a/gnu/packages/mail.scm
+++ b/gnu/packages/mail.scm
@@ -1370,20 +1370,19 @@ invoking @command{notifymuch} from the post-new hook.")
                       (substitute* (find-files "test" "\\.sh$")
                         (("/bin/sh") (which "sh"))))))))
     (native-inputs
-     `(("bash-completion" ,bash-completion)
-       ("pkg-config" ,pkg-config)
-       ("python" ,python)
-       ("python-docutils" ,python-docutils)
-       ("sphinx" ,python-sphinx)
-       ("texinfo" ,texinfo)
-
-       ;; The following are required for tests only.
-       ("emacs" ,emacs-no-x)    ; -minimal lacks libxml, needed for some tests
-       ("which" ,which)
-       ("dtach" ,dtach)
-       ("gnupg" ,gnupg)
-       ("man" ,man-db)
-       ("perl" ,perl)))
+     (list bash-completion
+           pkg-config
+           python
+           python-docutils
+           python-sphinx
+           texinfo
+           ;; The following are required for tests only.
+           emacs-no-x ; -minimal lacks libxml, needed for some tests
+           which
+           dtach
+           gnupg
+           man-db
+           perl))
     (inputs
      (list glib gmime talloc xapian zlib))
     (home-page "https://notmuchmail.org/")