summary refs log tree commit diff
diff options
context:
space:
mode:
authorStefan Reichör <stefan@xsteve.at>2021-02-12 22:51:54 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2021-02-15 11:37:58 +0100
commitadae5d75b6029b5d034030cff24e1ba4d8b3144a (patch)
treef4a6a524f222283a36bb3e3e142347e766bb02fd
parent8acedeb3a97e00eaaba6c1b58eae931d039c76a6 (diff)
downloadguix-adae5d75b6029b5d034030cff24e1ba4d8b3144a.tar.gz
gnu: Add run.
* gnu/packages/task-runners.scm (run): New variable.

Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/task-runners.scm49
2 files changed, 50 insertions, 0 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index ad6e02116e..250901f6d9 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -533,6 +533,7 @@ GNU_SYSTEM_MODULES =				\
   %D%/packages/synergy.scm			\
   %D%/packages/syndication.scm			\
   %D%/packages/task-management.scm		\
+  %D%/packages/task-runners.scm			\
   %D%/packages/tbb.scm				\
   %D%/packages/tcl.scm				\
   %D%/packages/telegram.scm                 \
diff --git a/gnu/packages/task-runners.scm b/gnu/packages/task-runners.scm
new file mode 100644
index 0000000000..49a07fa3bd
--- /dev/null
+++ b/gnu/packages/task-runners.scm
@@ -0,0 +1,49 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2021 Stefan Reichör <stefan@xsteve.at>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages task-runners)
+  #:use-module ((guix licenses) #:prefix license:)
+  #:use-module (guix packages)
+  #:use-module (guix git-download)
+  #:use-module (gnu packages golang)
+  #:use-module (guix build-system go))
+
+(define-public run
+  (package
+    (name "run")
+    (version "0.7.2")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/TekWizely/run")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "17n11lqhywq4z62w2rakdq80v7mxf83rgln19vj4v4nxpwd2hjjw"))))
+    (build-system go-build-system)
+    (propagated-inputs
+     `(("go-github-com-tekwizely-go-parsing" ,go-github-com-tekwizely-go-parsing)))
+    (arguments
+     `(#:import-path "github.com/tekwizely/run"))
+    (synopsis "Easily manage and invoke small scripts and wrappers")
+    (description
+     "Run is a tool to easily manage and invoke small scripts and wrappers by
+using a Runfile.")
+    (home-page "https://github.com/TekWizely/run")
+    (license license:expat)))