summary refs log tree commit diff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2018-02-12 21:58:44 +0100
committerRicardo Wurmus <rekado@elephly.net>2018-02-13 13:37:34 +0100
commitb28f0ffab35079c1d5fa990d17d0ef383f11ab6d (patch)
tree3bc7a91425594984eb5e5c92fd5969949476ee4c
parent3657bd1faa16d8a074c8867b6d9bb550bd415858 (diff)
downloadguix-b28f0ffab35079c1d5fa990d17d0ef383f11ab6d.tar.gz
gnu: Add ghc-refact.
* gnu/packages/haskell.scm (ghc-refact): New variable.
-rw-r--r--gnu/packages/haskell.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index e9e46a30b2..8395fba094 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -1038,6 +1038,28 @@ patterns as per the HaRP extension as well as HSX-style embedded XML syntax.")
 @code{haskell-src-exts} trees.")
     (license license:bsd-3)))
 
+(define-public ghc-refact
+  (package
+    (name "ghc-refact")
+    (version "0.3.0.2")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "https://hackage.haskell.org/package/"
+                           "refact/refact-"
+                           version ".tar.gz"))
+       (sha256
+        (base32
+         "0v0zxcx29b8jxs2kgy9csykqcp8kzhdvyylw2xfwmj4pfxr2kl0a"))))
+    (build-system haskell-build-system)
+    (home-page "http://hackage.haskell.org/package/refact")
+    (synopsis "Specify refactorings to perform with apply-refact")
+    (description
+     "This library provides a datatype which can be interpreted by
+@code{apply-refact}.  It exists as a seperate library so that applications can
+specify refactorings without depending on GHC.")
+    (license license:bsd-3)))
+
 (define-public hlint
   (package
     (name "hlint")