summary refs log tree commit diff
diff options
context:
space:
mode:
author宋文武 <iyzsong@gmail.com>2016-06-25 22:49:39 +0800
committer宋文武 <iyzsong@gmail.com>2016-06-25 22:52:57 +0800
commitb49504fd8c2f61fe5aae27598e5a475de1f9494b (patch)
tree907ae32ce77d96f56685b9e05de600f135e98e02
parentaebd383d04b351465cfb14e4fd0949b67d4b282e (diff)
downloadguix-b49504fd8c2f61fe5aae27598e5a475de1f9494b.tar.gz
gnu: Add python-pyaml and python2-pyaml.
* gnu/packages/python.scm (python-pyaml, python2-pyaml): New variables.
-rw-r--r--gnu/packages/python.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 7f3f95d142..80715133c3 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -9569,3 +9569,28 @@ addresses, and phone numbers.")
        `(("python2-ipaddress" ,python2-ipaddress)
          ,@(package-native-inputs base))))))
 
+(define-public python-pyaml
+  (package
+    (name "python-pyaml")
+    (version "15.8.2")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "pyaml" version))
+              (sha256
+               (base32
+                "1f5m28vkh4ksq3d80d8mmd2z8wxvc3mgy2pmrv2751dm2xgznm4w"))))
+    (build-system python-build-system)
+    (native-inputs
+     `(("python-setuptools" ,python-setuptools)))
+    (propagated-inputs
+     `(("python-pyyaml" ,python-pyyaml)))
+    (home-page "https://github.com/mk-fg/pretty-yaml")
+    (synopsis "YAML pretty-print library for Python")
+    (description
+     "pyaml is a PyYAML based python module to produce pretty and readable
+YAML-serialized data.")
+    (license (non-copyleft "http://www.wtfpl.net/txt/copying/"))))
+
+(define-public python2-pyaml
+  (package-with-python2 python-pyaml))
+