summary refs log tree commit diff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2023-07-11 16:36:55 +0200
committerRicardo Wurmus <rekado@elephly.net>2023-07-12 14:29:09 +0200
commitb4cafa71ae50fd2a5f0f24abf6b4b77ba5227ff6 (patch)
treea3d6b5e8d384a67c46e3d5db9d11b8d2c266e8ae
parent990bac0ea5daae426801df9b64e67d51a9316d8d (diff)
downloadguix-b4cafa71ae50fd2a5f0f24abf6b4b77ba5227ff6.tar.gz
gnu: Add r-saturn.
* gnu/packages/bioconductor.scm (r-saturn): New variable.
-rw-r--r--gnu/packages/bioconductor.scm34
1 files changed, 34 insertions, 0 deletions
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 840a9cdde8..a49a00ea1d 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -8803,6 +8803,40 @@ differential expression analysis, RNAseq data and related problems.")
     ;; Any version of the LGPL
     (license license:lgpl3+)))
 
+(define-public r-saturn
+  (package
+    (name "r-saturn")
+    (version "1.8.0")
+    (source (origin
+              (method url-fetch)
+              (uri (bioconductor-uri "satuRn" version))
+              (sha256
+               (base32
+                "0frm7iblxkc8ajcdqrfgsvf4krn6x8cr3mx7fnzq06xij0mqm3sj"))))
+    (properties `((upstream-name . "satuRn")))
+    (build-system r-build-system)
+    (propagated-inputs (list r-biocparallel
+                             r-boot
+                             r-ggplot2
+                             r-limma
+                             r-locfdr
+                             r-matrix
+                             r-pbapply
+                             r-summarizedexperiment))
+    (native-inputs (list r-knitr))
+    (home-page "https://github.com/statOmics/satuRn")
+    (synopsis
+     "Analysis of differential transcript usage for scRNA-seq applications")
+    (description
+     "satuRn provides a framework for performing differential transcript usage
+analyses.  The package consists of three main functions.  The first function,
+@code{fitDTU}, fits quasi-binomial generalized linear models that model
+transcript usage in different groups of interest.  The second function,
+@code{testDTU}, tests for differential usage of transcripts between groups of
+interest.  Finally, @code{plotDTU} visualizes the usage profiles of
+transcripts in groups of interest.")
+    (license license:artistic2.0)))
+
 (define-public r-scannotatr
   (package
     (name "r-scannotatr")