summary refs log tree commit diff
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2021-01-16 10:46:02 +0000
committerChristopher Baines <mail@cbaines.net>2021-01-16 11:13:09 +0000
commitb52bf667394991affcfba77bc72ed3d6e0b4d540 (patch)
treed32e342f59095ab5d59a92ea8608d250e135365b
parent74a83afdf5d518b812d939c394eb259c0fa5aa88 (diff)
downloadguix-b52bf667394991affcfba77bc72ed3d6e0b4d540.tar.gz
gnu: ruby-method-source: Remove unnecessary dependency on git.
* gnu/packages/ruby.scm (ruby-method-source)[arguments]: Patch Rakefile to use
find rather than git.
[native-inputs]: Remove git.
-rw-r--r--gnu/packages/ruby.scm12
1 files changed, 9 insertions, 3 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index c5b1af79d3..b811cbd2c4 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -5020,10 +5020,16 @@ both CSS3 selector and XPath 1.0 support.")
          "1pnyh44qycnf9mzi1j6fywd5fkskv3x7nmsqrrws0rjn5dd4ayfp"))))
     (build-system ruby-build-system)
     (arguments
-     `(#:test-target "spec"))
+     `(#:test-target "spec"
+       #:phases
+       (modify-phases %standard-phases
+         (add-after 'unpack 'remove-git-ls-files
+           (lambda* (#:key outputs #:allow-other-keys)
+             (substitute* "Rakefile"
+               (("git ls-files") "find . -type f"))
+             #t)))))
     (native-inputs
-     `(("ruby-rspec" ,ruby-rspec)
-       ("git" ,git)))
+     `(("ruby-rspec" ,ruby-rspec)))
     (synopsis "Retrieve the source code for Ruby methods")
     (description "Method_source retrieves the source code for Ruby methods.
 Additionally, it can extract source code from Proc and Lambda objects or just