summary refs log tree commit diff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2022-10-30 02:00:01 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2022-10-30 02:00:03 +0100
commitbb453af580ef92b843d02ef3f2b0c6d9ecfc132a (patch)
tree17ed7087e41b069a3b5824bd5036767f0db3dc7f
parenta350ee803c2b2611baadafe4ac008d5272cdd526 (diff)
downloadguix-bb453af580ef92b843d02ef3f2b0c6d9ecfc132a.tar.gz
gnu: jetring: Update to 0.31.
* gnu/packages/gnupg.scm (jetring): Update to 0.31.
[arguments]: Don't explicitly return #t from phases.
-rw-r--r--gnu/packages/gnupg.scm12
1 files changed, 5 insertions, 7 deletions
diff --git a/gnu/packages/gnupg.scm b/gnu/packages/gnupg.scm
index af4414fb9b..210b1ab8b3 100644
--- a/gnu/packages/gnupg.scm
+++ b/gnu/packages/gnupg.scm
@@ -1167,7 +1167,7 @@ over.")
 (define-public jetring
   (package
     (name "jetring")
-    (version "0.30")
+    (version "0.31")
     (source
       (origin
         (method git-fetch)
@@ -1181,14 +1181,13 @@ over.")
     (arguments
      '(#:phases
        (modify-phases %standard-phases
-         (delete 'configure) ; no configure script
+         (delete 'configure)            ; no configure script
          (add-before 'install 'hardlink-gnupg
            (lambda* (#:key inputs #:allow-other-keys)
              (let ((gpg (search-input-file inputs "/bin/gpg")))
                (substitute* (find-files "." "jetring-[[:alpha:]]+$")
                  (("gpg -") (string-append gpg " -"))
-                 (("\\\"gpg\\\"") (string-append "\"" gpg "\"")))
-               #t)))
+                 (("\\\"gpg\\\"") (string-append "\"" gpg "\""))))))
          (replace 'install
            (lambda* (#:key outputs #:allow-other-keys)
              (let* ((out (assoc-ref outputs "out"))
@@ -1199,9 +1198,8 @@ over.")
                (for-each (lambda (file)
                            (install-file file (string-append man "/man1/")))
                          (find-files "." ".*\\.1$"))
-               (install-file "jetring.7" (string-append man "/man7/"))
-               #t))))
-       #:tests? #f)) ; no test phase
+               (install-file "jetring.7" (string-append man "/man7/"))))))
+       #:tests? #f))                    ; no tests
     (inputs
      (list gnupg perl))
     (home-page "https://joeyh.name/code/jetring/")