summary refs log tree commit diff
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2022-06-15 12:02:04 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2022-07-04 16:10:51 +0200
commitbc6780ee9a3b7a0b96d2e27a11cd2a93da31e37e (patch)
treee3f48332f8b50225a3934255060440404b78b4f5
parent477e561a46a5d2fe553122396dc376745aa1c9f5 (diff)
downloadguix-bc6780ee9a3b7a0b96d2e27a11cd2a93da31e37e.tar.gz
gnu: Add python-geomet.
* gnu/packages/python-xyz.scm (python-geomet): New variable.
-rw-r--r--gnu/packages/python-xyz.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 1d43049776..9b19d4ee28 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -30006,3 +30006,23 @@ with it, and it also implements recommendations from the
 and names, built from Unicode CLDR and the IANA subtag registry, if you
 install @code{python-language-data}.")
     (license license:expat)))
+
+(define-public python-geomet
+  (package
+    (name "python-geomet")
+    (version "0.3.0")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "geomet" version))
+              (sha256
+               (base32
+                "06rfvadx5dr5xrgsc5bsmqil9c9kff6i13xl988gy0gfg0cl2lnb"))))
+    (build-system python-build-system)
+    (propagated-inputs (list python-click python-six))
+    (home-page "https://github.com/geomet/geomet")
+    (synopsis "Convert GeoJSON to WKT/WKB (Well-Known Text/Binary) or
+GeoPackage Binary")
+    (description "This package provides utilities and functions for converting
+GeoJSON to WKT/WKB (Well-Known Text/Binary) or GeoPackage Binary, and vice
+versa.  Extended WKB/WKT are also supported.")
+    (license license:asl2.0)))