summary refs log tree commit diff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-10-25 14:00:12 +0300
committerEfraim Flashner <efraim@flashner.co.il>2021-10-25 14:01:32 +0300
commitc8c35af8ac7c47592525c54aff2b2a434c4e4498 (patch)
treeccdd3833b7b30f0c2d357c0a570064a55dd5ed43
parenta0400dc9a5b5614d0d732bc07aeb7e83746c1db1 (diff)
downloadguix-c8c35af8ac7c47592525c54aff2b2a434c4e4498.tar.gz
gnu: python-pandas: Fix building with pytest-6.
* gnu/packages/python-science.scm (python-pandas)[arguments]: In custom
'check phase adjust to not fail tests with missing test data.
-rw-r--r--gnu/packages/python-science.scm3
1 files changed, 3 insertions, 0 deletions
diff --git a/gnu/packages/python-science.scm b/gnu/packages/python-science.scm
index 203e146dbc..dcd5a5045d 100644
--- a/gnu/packages/python-science.scm
+++ b/gnu/packages/python-science.scm
@@ -365,6 +365,9 @@ of the SGP4 satellite tracking algorithm.")
                      (getcwd) "/build/"
                      (first (scandir "build"
                                      (cut string-prefix? "lib." <>))))))
+               (substitute* "pyproject.toml"
+                 ;; Not all data files are distributed with the tarball.
+                 (("--strict-data-files ") ""))
                (with-directory-excursion build-directory
                  (when tests?
                    (invoke "pytest" "-vv" "pandas" "--skip-slow"