summary refs log tree commit diff
diff options
context:
space:
mode:
authorJosselin Poiret <dev@jpoiret.xyz>2023-03-01 16:32:31 +0100
committerJosselin Poiret <dev@jpoiret.xyz>2023-06-04 10:59:30 +0200
commitcc67085077c06b560840d24b3d00624313904206 (patch)
treea8e09fb95ca802f23d00fc14541000605f0638ea
parent89f8fc9c95791acc402444d09dfb503f494b1db8 (diff)
downloadguix-cc67085077c06b560840d24b3d00624313904206.tar.gz
gnu: Add ghc-vector-hashtables.
* gnu/packages/haskell-xyz.scm (ghc-vector-hashtables): New variable.
-rw-r--r--gnu/packages/haskell-xyz.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index 9852fdcc8b..a819698710 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -13329,6 +13329,27 @@ the vector; then you can execute the builder to actually produce the
 vector.")
     (license license:expat)))
 
+(define-public ghc-vector-hashtables
+  (package
+    (name "ghc-vector-hashtables")
+    (version "0.1.1.2")
+    (source (origin
+              (method url-fetch)
+              (uri (hackage-uri "vector-hashtables" version))
+              (sha256
+               (base32
+                "0hrjvy9qg1m5g3w91zxy4syqmp8jk7ajjbxbzkhy282dwfigkyd2"))))
+    (build-system haskell-build-system)
+    (inputs (list ghc-primitive ghc-vector ghc-hashable))
+    (native-inputs (list ghc-hspec ghc-quickcheck ghc-quickcheck-instances
+                         hspec-discover))
+    (home-page "https://github.com/klapaucius/vector-hashtables#readme")
+    (synopsis "Efficient vector-based mutable hashtables implementation")
+    (description
+     "This package provides efficient vector-based hashtable implementation
+similar to .NET Generic Dictionary implementation (at the time of 2015).")
+    (license license:bsd-3)))
+
 (define-public ghc-vector-th-unbox
   (package
     (name "ghc-vector-th-unbox")