summary refs log tree commit diff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-05-07 12:54:11 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-05-07 13:04:25 -0400
commitd1aba42ad4e1909faa21d484975c5954c778e002 (patch)
tree9cbdae0ed0156e97765bed5999fcb09909d471b6
parent62f31c9d50db724e4fb6f7c951cea2f0f53b03dd (diff)
downloadguix-d1aba42ad4e1909faa21d484975c5954c778e002.tar.gz
gnu: nss-certs: Update to 3.88.1.
* gnu/packages/certs.scm (nss-certs): Update to 3.88.1.
-rw-r--r--gnu/packages/certs.scm4
-rw-r--r--gnu/packages/nss.scm5
2 files changed, 5 insertions, 4 deletions
diff --git a/gnu/packages/certs.scm b/gnu/packages/certs.scm
index 122882980b..58b4d50ec8 100644
--- a/gnu/packages/certs.scm
+++ b/gnu/packages/certs.scm
@@ -131,7 +131,7 @@ that was originally contributed to Debian.")
     ;; XXX We used to refer to the nss package here, but that eventually caused
     ;; module cycles.  The below is a quick copy-paste job that must be kept in
     ;; sync manually.  Surely there's a better way…?
-    (version "3.85")
+    (version "3.88.1")
     (source (origin
               (method url-fetch)
               (uri (let ((version-with-underscores
@@ -142,7 +142,7 @@ that was originally contributed to Debian.")
                       "nss-" version ".tar.gz")))
               (sha256
                (base32
-                "15yj2gddlp68wj1k9q4q70vs6r7zx5qkbavcppmls5di212xdndg"))
+                "15il9fsmixa1r4446zq1wl627sg0hz9h67w6kjxz273xz3nl7li7"))
               ;; Create nss.pc and nss-config.
               (patches (search-patches "nss-3.56-pkgconfig.patch"
                                        "nss-getcwd-nonnull.patch"
diff --git a/gnu/packages/nss.scm b/gnu/packages/nss.scm
index 7bb239dd27..8088f23aa6 100644
--- a/gnu/packages/nss.scm
+++ b/gnu/packages/nss.scm
@@ -103,8 +103,9 @@ in the Mozilla clients.")
 (define-public nss
   (package
     (name "nss")
-    ;; Also update and test the nss-certs package, which duplicates version and
-    ;; source to avoid a top-level variable reference & module cycle.
+    ;; IMPORTANT: Also update and test the nss-certs package, which duplicates
+    ;; version and source to avoid a top-level variable reference & module
+    ;; cycle.
     (version "3.88.1")
     (source (origin
               (method url-fetch)