summary refs log tree commit diff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2021-01-12 09:26:30 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2021-01-12 11:48:39 +0100
commitdd42c528dbaaaf7380a53c3eef92789bce738d89 (patch)
tree58354683dd2f5d62b6e5dadef4cc1a3a6434b66c
parent09d800cb42f577d03e6e8864bbeecc2617dba6b8 (diff)
downloadguix-dd42c528dbaaaf7380a53c3eef92789bce738d89.tar.gz
gnu: scribus: Build with podofo 0.9.6.
* gnu/packages/scribus.scm (podofo-for-scribus): New private variable.
(scribus)[inputs]: Use it instead of the regular podofo.

Reported by Vincent Legoll <vincent.legoll@gmail.com>.
-rw-r--r--gnu/packages/scribus.scm26
1 files changed, 24 insertions, 2 deletions
diff --git a/gnu/packages/scribus.scm b/gnu/packages/scribus.scm
index f699824a05..9a6b75333b 100644
--- a/gnu/packages/scribus.scm
+++ b/gnu/packages/scribus.scm
@@ -4,7 +4,7 @@
 ;;; Copyright © 2017, 2018 Nicolas Goaziou <mail@nicolasgoaziou.fr>
 ;;; Copyright © 2018 Clément Lassieur <clement@lassieur.org>
 ;;; Copyright © 2019 Marius Bakke <mbakke@fastmail.com>
-;;; Copyright © 2020 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2020, 2021 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -46,6 +46,26 @@
   #:use-module (gnu packages tls)
   #:use-module (gnu packages xml))
 
+(define podofo-for-scribus
+  (package
+    (inherit podofo)
+    (version "0.9.6")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "mirror://sourceforge/podofo/podofo/" version
+                           "/podofo-" version ".tar.gz"))
+       (sha256
+        (base32 "0wj0y4zcmj4q79wrn3vv3xq4bb0vhhxs8yifafwy9f2sjm83c5p9"))
+       (modules '((guix build utils)))
+       (snippet
+        '(begin
+           ;; Fix the build with CMake 3.12.0.
+           (substitute* "test/TokenizerTest/CMakeLists.txt"
+             (("\\$\\{CMAKE_COMMAND\\}")
+              "true"))
+           #t))))))
+
 (define-public scribus
   (package
     (name "scribus")
@@ -96,7 +116,9 @@
        ("libxml2" ,libxml2)
        ("libzmf" ,libzmf)
        ("openssl" ,openssl)
-       ("podofo" ,podofo)
+       ;; Scribus 1.5.6.1 does not build with later versions, see
+       ;; <https://bugs.scribus.net/view.php?id=16427>.
+       ("podofo" ,podofo-for-scribus)
        ("poppler" ,poppler)
        ("python" ,python)               ; need Python library
        ("qtbase" ,qtbase)