summary refs log tree commit diff
diff options
context:
space:
mode:
authorjgart <jgart@dismail.de>2022-10-30 20:00:48 -0500
committerChristopher Baines <mail@cbaines.net>2022-11-03 17:37:54 +0100
commitdde299df48cffb487b3378cbbd0fcbd03fcfd0e1 (patch)
treeb1798f34cb342bee9e8870b06a2c51b2fa71f875
parent22130892802c61f93940aa79065de12efd9319ea (diff)
downloadguix-dde299df48cffb487b3378cbbd0fcbd03fcfd0e1.tar.gz
gnu: Add python-jsonalias.
* gnu/packages/python-xyz.scm (python-jsonalias): New variable.

Signed-off-by: Christopher Baines <mail@cbaines.net>
-rw-r--r--gnu/packages/python-xyz.scm19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 6a792ba73a..00cc7fe01e 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -2985,6 +2985,25 @@ after Andy Lester’s Perl module WWW::Mechanize.")
 audio playback capability for Python 3 on OSX, Windows, and Linux.")
     (license license:expat))) ; MIT license
 
+(define-public python-jsonalias
+  (package
+    (name "python-jsonalias")
+    (version "0.1.1")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "jsonalias" version))
+              (sha256
+               (base32
+                "0sd7c3vyvfhhpnan77ax4f0x1whjcb5iz7jhjky7kmcpaf9lvw34"))))
+    (build-system python-build-system)
+    (arguments (list #:tests? #f)) ; There are no tests.
+    (home-page "https://github.com/kevinheavey/jsonalias/")
+    (synopsis "JSON type alias for Python")
+    (description
+     "This package provides a microlibrary that defines a JSON type alias for
+Python.")
+    (license license:expat)))
+
 (define-public python-simplejson
   (package
     (name "python-simplejson")