summary refs log tree commit diff
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2021-04-16 17:18:57 -0400
committerLeo Famulari <leo@famulari.name>2021-04-16 17:21:04 -0400
commite12210dc92098d8581cea3007d57dbb6be16bb41 (patch)
tree0d1bf3bc4bab53f4815e0b6533ba057a458f95dd
parent76b6c61609fd8352ce01059307cf1aec85b8d0df (diff)
downloadguix-e12210dc92098d8581cea3007d57dbb6be16bb41.tar.gz
gnu: GnuTLS: Absorb grafted replacement.
* gnu/packages/tls.scm (gnutls)[source]: Add 'gnutls-CVE-2021-20231.patch' and
'gnutls-CVE-2021-20232.patch'.
[replacement]: Remove field.
(gnutls/fixed): Remove variable.
-rw-r--r--gnu/packages/tls.scm14
1 files changed, 3 insertions, 11 deletions
diff --git a/gnu/packages/tls.scm b/gnu/packages/tls.scm
index 25dcdd7228..fee6276674 100644
--- a/gnu/packages/tls.scm
+++ b/gnu/packages/tls.scm
@@ -165,7 +165,6 @@ living in the same process.")
   (package
     (name "gnutls")
     (version "3.6.15")
-    (replacement gnutls/fixed)
     (source (origin
               (method url-fetch)
               ;; Note: Releases are no longer on ftp.gnu.org since the
@@ -174,7 +173,9 @@ living in the same process.")
                                   (version-major+minor version)
                                   "/gnutls-" version ".tar.xz"))
               (patches (search-patches "gnutls-skip-trust-store-test.patch"
-                                       "gnutls-cross.patch"))
+                                       "gnutls-cross.patch"
+                                       "gnutls-CVE-2021-20231.patch"
+                                       "gnutls-CVE-2021-20232.patch"))
               (sha256
                (base32
                 "0n0m93ymzd0q9hbknxc2ycanz49sqlkyyf73g9fk7n787llc7a0f"))))
@@ -257,15 +258,6 @@ required structures.")
     (properties '((ftp-server . "ftp.gnutls.org")
                   (ftp-directory . "/gcrypt/gnutls")))))
 
-(define gnutls/fixed
-  (package
-    (inherit gnutls)
-    (source (origin
-              (inherit (package-source gnutls))
-              (patches (append (search-patches "gnutls-CVE-2021-20231.patch"
-                                               "gnutls-CVE-2021-20232.patch")
-                               (origin-patches (package-source gnutls))))))))
-
 (define-public gnutls/guile-2.0
   ;; GnuTLS for Guile 2.0.
   (package/inherit gnutls