summary refs log tree commit diff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2012-07-07 22:50:27 +0200
committerLudovic Courtès <ludo@gnu.org>2012-07-07 22:51:40 +0200
commite1e7b29aae2f2acda47c3d0c083096b0ee37574f (patch)
tree55583546b926b50e6f4150b10372ab1a4517ff89
parent162dcc8b4ce68e858e52ce9e74119e11fcf0b8c3 (diff)
downloadguix-e1e7b29aae2f2acda47c3d0c083096b0ee37574f.tar.gz
build: Adjust tests to Automake 1.12.
* Makefile.am (TESTS_ENVIRONMENT): Remove `guile' invocation.  Add
  semicolons, and export the variables as shown in the Automake 1.12
  manual.
  (LOG_COMPILER): New variable, with `guile' invocation.
-rw-r--r--.gitignore1
-rw-r--r--Makefile.am9
2 files changed, 7 insertions, 3 deletions
diff --git a/.gitignore b/.gitignore
index 29879a5613..a211be9853 100644
--- a/.gitignore
+++ b/.gitignore
@@ -35,3 +35,4 @@ config.cache
 /po/stamp-po
 /po/guix.pot
 /guix-build
+/tests/*.trs
diff --git a/Makefile.am b/Makefile.am
index a096c9b95d..8f8cb12c85 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -48,9 +48,12 @@ TESTS =						\
   tests/build-utils.scm				\
   tests/packages.scm
 
-TESTS_ENVIRONMENT =							\
-  NIXPKGS="$(NIXPKGS)"							\
-  GUILE_LOAD_COMPILED_PATH="$(top_builddir):$$GUILE_LOAD_COMPILED_PATH"	\
+TESTS_ENVIRONMENT =								\
+  NIXPKGS="$(NIXPKGS)";								\
+  GUILE_LOAD_COMPILED_PATH="$(top_builddir):$$GUILE_LOAD_COMPILED_PATH";	\
+  export NIXPKGS GUILE_LOAD_COMPILED_PATH;
+
+LOG_COMPILER =					\
   $(GUILE) --no-auto-compile -L "$(top_srcdir)"
 
 EXTRA_DIST = build-aux/config.rpath $(TESTS)